Make2D suddenly not working

I haven’t had any issues with the Make2D command in rhino 6, in fact it greatly improved in 6…until yesterday. all of a sudden it’s not working properly. when it does, it takes FOREVER, and i can only use the command 2 or 3 times until it refuses to work at all and i have to force the program to quit. the only thing i’ve done before this issue came up is load a new plugin. its very possible that it’s an issue with my machine, but since i’ve had other bugs with the latest build i though i’d see if anyone else has experience a similar issue.

which plugin did you install?

Hello - the test would be to disable the new plug-in in Options > Plug-ins page and then restart Rhino and see if the problem persists.

-Pascal

i installed ‘Xirus CAD’

https://www.food4rhino.com/app/xiruscad-alpha?fbclid=IwAR2-uluc__UK3PdnDuiHFXpzfSaphb8k6d7yC5PVFxYzgdQuL6De1AMxDKc

i tried that…still a problem. i just can’t figure out what would have happened with my computer overnight to have this issue come up. i was wondering if it could have anything to do with the latest rhino build, since i’ve had a couple other little issues, but it seems more likely that it’s something with my computer i guess.

Hello - the other thing to try is to start Rhino in Safe Mode and see… also, see if the problem is with specific files or across the board.

-Pascal

Apparently another question to keep in mind is: did Windows update itself overnight and change a driver or two?

1 Like

Hello everyone!
I’m facing the same issue! I modelled something for my portfolio back in October last year, and I even generated some Illustrator files of some details. The project was left on hold and just today I tried to make2D and flatten it, and it’s loading FOR ETERNITY
It goes until 99% in about 10minutes, but then it never leaves that stage.

The model itself is 8Mb with many blocks with the details

Does anybody managed to solve this?!

I already tried:
Exploding everything (but then it gets craaaazy heavy and not fun anymore -like 45Mb)
Following all the steps here: https://wiki.mcneel.com/rhino/make2dtips

Hi - please run the Rhino SystemInfo command and post the result here.
Also, can you post the file so that we can check what is going on?

Semi OpenedR5.3dm (7.9 MB)

My notebook is a bit old (has 5 years now) but has some ok specs I’d say
16GB RAM - Windows 10
GeForce GTX 860M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 382.05)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 5-1-2017
Driver Version: 22.21.13.8205
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Thanks for that information!
Since you are running Rhino 5, we know that it wasn’t an update of Rhino that is causing things to not work like they did in October. There has probably been a Windows update during this period, and since your GPU drivers are getting old, I would first try updating these to see if that makes a difference.

There’s an updated driver available here:
https://www.nvidia.com/Download/driverResults.aspx/144365/en-us

I will give it a try!
Thank you for the amazingly fast reply!