Make2d plan views not working?

It would be great if I could get this working.
I need to create front view line work of mesh objects but nothing gets created.
When I use make2d parallel view component nothing happens no line work is drawn.
If I use make2d Rhino View and designate a perspective view, line work is drawn
If I use the same component, make2d Rhino View, front or right no line work gets drawn

Can you post an image of your definition? How are you creating the the parallel view?

Hi @Japhy,

I tried to narrow it down. You can use the same definition in both files. In the attached files the file where make2d works with the definition has regular rhino viewports.

The file that contains my custom arrangement of viewports and names on two viewports, make 2d doesn’t create any curves in the output. I tried both true and false in the boolean toggle.

Also if you look at the output, when make 2d does succeeds it misses half of the lines.

In regular rhino try the Meshoutline tool with the provided mesh, that’s how I need my output to look.

If I could invoke the meshoutline command from a vbscript component and then move that output to where the mesh is, that is really what I am trying to achieve. I need to do it 40 times at forty different locations in the model.

Also what’s the syntax to get the rhino command meshoutline to work from Gh? I would so much appreciate it.

Thanks for your fast help and let me know if you need anything else,
Running—Rhino 7 SR11 2021-10-1 (Rhino 7, 7.11.21274.07001,
RM (6.2 KB)
Make2D_From_MeshFile_Not_Working.3dm (788.5 KB)
Make2D_From_MeshFile_Working.3dm (540.5 KB)


Too funny I didn’t realize I have to use the python component to use vbscript easily in gh.
So I merely had to add a python component to the canvas
and then after setting a mesh in x hint add this small bit of code to the editor…

import rhinoscriptsyntax as rs
a = rs.MeshOutline(x)

Nice now I can link my vbscripts and knowledge in Gh.
Keep up the great work so much to learn.

1 Like

Hi @Japhy I’ve been waiting to hear about this bug are you not doing anything? can’t get to happen from my example? It’s really vexing not when you have an example but never reply.

I missed this, will give look as soon as i’m caught up.

Thank you.