Make2D on mesh objects

Hi all,

Is there anyway Rhino can make2D on meshes? I’ve tried the make2d feature from SectionTool, which is not working on mesh objects. Any idea?

Edit: Here is another way I’ve tried —extracting wire-frames from meshes but the problem is if the geometry is complex Rhino either crash or very slow.


1 Like

Could you provide some input as to what you will use the result for?

V6 will have Make2d that works with meshes, if that gives you hope. For now, maybe MeshOutline may help get the curves you are after from a mesh.



Hi pascal and wim,

What a good news for Architecture students! :wink: Thanks!


Yes this gives me hope :sunny:

Can you just run Meshtonurb on your mesh, then make2d on the result? Yes you will get all of the mesh facets in your make2d output, but still a highly useable solution.

Have you tried MeshOutline?

Hi Careve,

I guess it depends on the complexity of geometry I made. I’m in the lab right now.I don’t have the file with me but I will post it later. Meshtonubrs definitely won’t work on this. I will share the file later. Please take close attention. Thanks!


Meshoutline is not for section drawings. I should say It’s a part of process if needed. What meshoutline gives is that it only extract mesh edges. Sometimes the architecture form needs to see the depth in section views. It’s created from Maya vector render. This is result I’d like to see…

Hi Kev- I can tell you that I tried V6 Make2d on this file or one very much like it that was posted here, and it worked but was by no means perfect. Defintely some cleanup involved, but it is a nasty mesh… did not, as I recall, pass Check with flying colors.


Thanks for the efforts, Pascal. :wink:

Hi Pascal,
Thanks for keeping us abreast of developments that is fantastic news.

Kev/Pascal/all: Am I missing something here, as to why meshtonurbs->make2d combination doesn’t work for this? Please explain if so. Attached is the test file from December, (its big, even after cropping, so I compressed to .zip) with the mesh and the resultant polysurf geometry after meshtonurbs, and the make2d result, which looks pretty good to me. Based on your comments above I don’t see how the triangular facets in the result would be a problem. (10.7 MB)

note: i’m not on the fastest machine at the moment(an older i7 @3.4GHz, only 8GB ram) so the make2d did take approx 2 minutes. But not a deal breaker, though would take longer for the whole model. I guess if you are on a much slower machine perhaps that would be a problem, but that would be an issue for any complex make2d you were undertaking.

Hi, Carve

Here is the process of Meshtonubrs from my machine. I just run this for 10mins.

CPU: 17-3770K overclocked to 4.30GHz
RAM: 12G 1600MHz

hhaha! well yeah if you run it on the whole darned thing! I’m pretty sure you can break that into smaller more manageable sections though.

nice question Kev

1 Like

Thank you the Meshtonub is working!!!