Make2D not working properly - Rhino 6 Windows

(Javier) #41

I meant 6.1 lol! It is strange but this version the make 2d works fine!


(Javier) #42

@wim is there anyway to downgrade rhino?


(Wim Dekeyser) #43

To which version? You are at 6.1 now?

(Javier) #46

6.9 or 6.10, one in wich make2d command works propperly! Thx @wim


(Javier) #47

yeap, sorry, i looked that this one appear like solved and i didnt know what i should do

(Wim Dekeyser) #48

I’m very confused now.
Can you take this one step at a time?
You report that you have a problem in 6.10. Is that correct?
You then downgraded to 6.1 where the same model works fine?
Have you tried 6.11?


Javier , you might try: in Tools/Option/ updates and statistics" entry to set the feed source(Update Frequency) to Service Release Candidate, it can surely help the team to fix asap any comming bug. Because your problem looks important.

(Javier) #50

@wim I have done first the make 2D command with the last version (6.10.18311.20531). It doesn´t work at all. All the lines that are projected are not shown in the make 2D command. Later, i have to present one section in 2D for my client so I have unistal Rhino and reinstall the version 6.1 (i have been very lucky cause i had under downloads folder the exe file that i downladed this year on january when rhino 6 was launched) and it works (but i have find other bugs that i know that this version of rhino has and has been solved in the next versions).

I think this is very importat, the last version that anyone can donwnload in the rhino website (6.10.18311.20531) the make2D command doesnt work at all.

Thx @wim and @piem for the replies

(Wim Dekeyser) #52

It doesn’t really matter which version is downloadable from the website. All users can download Release Candidates from within Rhino, as @piem described.

What matters is that we fix problems in the versions that we are working on (currently 6.11 and 6.12). Without a file, that will be very hard for us to do.

If you have a sensitive file that cannot be made public, you could upload it to us here:

Alternatively, please post a simplified model that still shows the issue but doesn’t contain sensitive information.

(Javier) #53

Hi @wim
sorry for the delay. I have asked for another rhino file that happends exactly the same…is really weirdm also if i try to make a render with vray, it doesn´t work…i think that the file is corrupted maybe because they have inserted big cad files embebed.

I hope that u find it useful and it helps to keep on improving rhino :wink: (4.4 MB)

(Pascal Golay) #54

Hi Javier - here is what I get from the view f1 - does that look like what you want or what you get now, if either…?

3DMake2D_PG.3dm (3.4 MB)


(Javier) #55

Hi Hi @Pascal

There are 2 cases in the make2D:

-In a perspective view without clipping plane, I get nothing. Completely empty.

  • In a perspective view with a clipping plane, I get only the section lines with the clipping plane. Really weird. (image attached)

Also, I have try to make a render with vray 3.60 plugin, and it doesnt work at all in this model. If iI copy and paste the geometry into another file of rhino, the render works, if not, i only see a clean white image.

Maybe @Pascal and @wim the file is corrupted or I dont know what happens in this file. I can try with other rhino model to see if it works and is a problem only related to this file or the problem is more serious and is related with the version of rhino

Thanks for your support

(Wim Dekeyser) #56

Hi @Javier_FQ

Have you tried Make2D on a new scene with a simple object?
I have been looking at your file for a while now, and nothing looks weird here. But when I opened the file, I got warnings saying

A linked block definition cannot find a file named
… \00.3DS\SITUACION.3dm
… \01.CAD\auxilares\ALZADO.dwg

… so, it could be that one of these causes things.

As for your statement about the ClippingPlane:

I couldn’t find any named views in your file that have an active ClippingPlane. How are you assigning your clipping plane?

(Javier) #57

Hi @wim

Yes, I have tried, and it works…I don´t know why in this rhino file it doesn´t work. The main difference with the other ones is that this one has large CAD files linked so maybe this is the reason why (but I still don´t understand why make 2D doesn’t work well even a CAD file is inserted)

About the clipping plane, I don´t remember @wim, maybe I deleted the clipping plane but I tried and I only got the section lines of the clipping plane.
Also, I remembered some problems with Vray plugin, the renders didn´t recognize the geometry

Thx for your efforts @wim

(Wim Dekeyser) #58

Thanks for that additional information!

If you could supply all linked files as well (e.g. upload to, we might be able to figure out what’s going on there.

(Lachlan) #59

I believe I’ve found a really simple fix for this problem. I apologize if there’s a more appropriate fix elsewhere, but the Make2D command is now working flawlessly. Like many of you, I was getting frustrated with the command dropping lines. In the case of hidden lines, they wouldn’t show up at all regardless of whether or not the box was checked on or off. Given that this command is one of my primary reasons for using the program, this is incredibly useful.

Step 1: With items selected, click the thickness button under the properties tab and ensure it is ON. For whatever reason, by default this is off for all objects within Rhino 6. Change the distance to 0.001 (this second part of step 1 may not be necessary, but it was the first thing I tried and now appears to be working).

Step 2: Run Make2D command.

Before doing this, the command was dropping lines and adding tangents indiscriminately. It rarely produced edges which were curved in view. As you can see above, this is no longer an issue. This has also fixed the hidden lines issue, although I didn’t include an image. After reviewing the result, there isn’t a single issue that required fixing.

Hope this helps. I’ll admit I’m no computer whiz, so I literally have no idea why this worked, but it did, and I hope it does for all of you too.

Happy New Year!

(Lachlan) #60

Appears to be working in other projections as well:

1 Like