Make2D Issue: Section Drawing creating hollow geometry with edges

Hi, I need help with a sectional drawing for a large scale project, Make2D is producing a hollow sectional model with extra ‘interior’ edges, which I do not want, and it will take too long to go around deleting all the lines produced in Make2D (in AutoCad). I’ve tried all settings on the Make2D properties and can’t seem to find a way around this.

Hi -

You have posted this in the “Rhino Developer” category - which implies an intent to customize Rhino by means of VB. NET, C#, C++, … Perhaps that is not the case?

In plain Rhino, there are no settings for removing internal edges when using Make2D. The only viable option is to use the viewport display with the clipping plane clipping your geometry.


This behavior has been known for about 10 years now… nothing has changed… total nonsense:

@wim: hopefully something will be done in v8 to fix this?

Hi -

At this point, I’m afraid that’s unlikely.
I imagine this requires a deeper dive into the core of the code and the developers have other big projects on their slates for Rhino 8.

It’s a shame. Really.