Make2d frustration

It frustrates me terribly.
I have a 430 objects, all generated allong the way in Grasshopper which are internalized in this short example.
The projection plane is way above all objects yet M2D generates only hidden lines.
Is there a trick? is there something I’m doing wrong here?
Whatever the combination with trees, booleans, clipping planes only worsen the output.

M2D (1.1 MB)

When I ran your definition in Rhino 7, I see the visible lines (see image below).
Do you still have problem getting the correct result?

Hi Rajaa
It’s utterly confusing. I have opened the file I’ve published, both in Rhino 7 and 8, on an new files and I got it working.
It didn’t work for me at all when inputs where generated in GH being part of a large formula.
Originally, it is linked with Rhino file which is in mm with very tight tolerance, can it be a problem?
I’ve struggled before with solidunion operation in GH. I’ve searched for help on this forum and I’ve been advised to change the tolerance from default to much tighter and it did the trick.
Seems like there is contradiction on what tolerance are being favoured by solid operations and Make2Ds.

I’ve cracked it. The trick was to play with Angle tolerance making it more loose than Absolute tolerance. These are the settings that works for me now.

Absolute tolerance 0.00001? Do you really need it that tight?

It’s the one that made a solid union work. It could be too much though, for sure but I am working on a steel elemnts with 1mm thickness, it needs quite tight tolerances.

Your model units are in millimeters, so the tolerance is relative to the same units. Do you need 0.00001 of the mm tolerance?