Make Mirror Copy NO default..how?


#1

Hi,
V4

Mirror
Even if I hit C and make copy : No the next time, within seconds even, I use Mirror its defaulted back to Yes.

Irritating and the sort of thing that shouldnt be.

How can I make it stay at No…forever !!!

Likewise Knot:Chord for Interpolate Points tool

Steve


(Pascal Golay) #2

Hi Steve, if you are working from a button, you can change the macro to

! _Mirror _Pause _Copy=_No

On the other hand, you can use the RememberCopyOptions command to set how Copy=Yes/No is used by all the transform commands that have a copy option. Be careful with this… you may not like what it does to other Copy=Yes/No settings.

-Pascal


#3

Hi,

I am going Transform>Mirror from top menu

does that count as a button ?

I wouldnt know how to change the macro…hows that done ?

Steve


(Wim Dekeyser) #4

No, it doesn’t.


(Willem Derks) #5

Hi Steve,

have a look at these links to get some info on how to customize buttons:

http://wiki.mcneel.com/developer/macroscriptsetup

http://www.rhino3dhelp.com/tutorials/creating-your-first-toolbar-button-macro/

http://docs.mcneel.com/rhino/5/help/en-us/user_interface/using_toolbars.htm

HTH
-Willem