Make 2D will not generate anything

Hi,

Im using make2d on Rhino 6 Windows and it will not generate any lines when a ‘complex curve’ is selected. By ‘complex curve’ i mean a curve which simply has multiple elements to it and can be exploded into a 100 or so parts- nothing Make2D has not done and converted before multiple times but for some reason now it is not working. I have given the file to a friend and it has worked on their computer. Make2D appears to work when anything else is selected and I have used Make2D on the items before - the problem is only appearing now after not using the computer during the winter break.

Any help?

Thanks,
Will

Hi Will - please post an example if you can.

-Pascal

If you run SelBadObjects, does the curve get selected? If it is a “bad” object, it might not pass Make2D. You can try selecting the curve, using Explode to explode it into segments, then while they are still selected, use Join to join them back up. That often fixes “bad” curve objects.

No Bad Objects selected.

I have tried exploding it and the curve makes2D but only when you select a very small part of it and doesnt work when you join it back together

OK, as Pascal said, please post a file with just the curve…

Its hard to capture the problem but the selected lines are examples of ones that cause problems, make2D runs for a couple of seconds then produce nothing. When selecting an individual block (the small lines) or any of the extruded forms or blocks they make2d fine its just when any of these types of lines are selected the whole thing fails and produces nothing

Hello - we’ll need the curve in a Rhino file, an image by itself is not useful… If the curve is not one that you can share publicly, please post via www.rhino3d.com/upload. Please include a link to this topic in your accompanying note so we know what it’s about.

-Pascal

The file is particularly large but can copy it into its own rhino file - there is multiple curves which appear to the problem as well. Im not sure it has anything to do with the file since I have tried it on another computer and it works? However, I can still send the file if needed

Hello - yeah, just export one or two curves to a new file and try Make2d in that - if it is still goofy, send us the file.

thanks,

-Pascal

Ive tried copying them into a new file and it doesnt work either… will send a couple of curves in a new file in a minute but suspect on your computer that it will work

Also, run the SystemInfo command in both the Rhino where this does not work, and on one where it does and send the output .

-Pascal

Can send that as well but it wont work in either file is the point - it will only work on certain curves

Hi Willy - OK - what I’d like, if possible, is

  1. Curves that fail in make2d at least sometimes.
  2. SystemInfo for the machine, if it is machine specific, where this fails. System info for a ‘working’ machine would not hurt…

thanks,

-Pascal

<a class=“attachment” href="/uploCurves.3dm (75.8 KB)
ads/default/original/3X/8/8/88cabd2a19c8128d7c24c9b4ab125b8b72a69aea.txt">systeminfo.txt (1.6 KB)

That is both the attachments requested. In the curve files there is a make2D of the curves that are possible and those not included in this make2d are those that cause the command to fail.

systeminfo.txt (1.6 KB)

Hi Willy - thanks, this fails here as well.
https://mcneel.myjetbrains.com/youtrack/issue/RH-50281

-Pascal

oh wow! didnt expect that! - It happened as well when i drew curves on rhino as well?

Hi Will,
in my opinion the problem is due to the model’s units setted to millimeters.
Changing to Meters (and scaling all to 0.001) the make 2D works (your model is very large and don’t understand why using mm…).
Hope this help you.
Ciao

Hi Lucio,

Can confirm that scaling it down did work! thanks very much! Did scale it back up as i prefer working in mm as the original model had elements that interacted at that scale but it didn’t work.

Thanks for your help!

Will

If the tolerance was set to .1 mm or 1mm instead of .001mm It would work as well. You have curves that are 6km long with tolerance set to .001mm this is finer than 1 part in a billion.

1 Like