Make 2D not working

I’m developing a rather complex shapediver-project.
Now I have a problem with the make2D-component.
The strange thing is that it works in Grasshopper locally, and the same definition worked at Shapediver earlier…

What’s not the problem/What I’ve double-checkd from other resources:

  • All data is mesh or curves (geometry is not linked to a rhino-doc)
  • Data is flatterned
  • Viewports are made from internalised rectangles.

Is it possible that the definition times out?
(As mentioned, the solution is rather heavy, uses 5-10 seconds to refresh)

Yes, it is possible that a complex definition exceeds allowed computation time in which case you should get a warning. Did you get one? How long does it take locally?

It would also help if you could post a minimal Grasshopper definition reproducing the issue.

Thanks for the quick reply.
The computation time of the make2D is about 1 second.

I now tried to internalize the geometry that was the make2D-input (Not letting shapediver generate a 3D-geometry.) It now works well. Same components, only difference is that the shapediver-model does nothing else than generating a 2D-model.

I did not receive any errors. Not until I was choosing a perspective make2D.
Files and links of the simplified model is attached[|attachment] (193.6 KB)

Make2D for the Perspectiv view in definition you posted takes about 17 seconds locally and it hits the computation time limit in ShapeDiver.

Try optimising your model as explained below or use isometric view instead if can’t simplify the geometry.

My issue is that the Make2D-components drawings does not generate in the original model.
In the original model, I do not get any warning and the resulting export pdf contains all elements except the Make2D-curves.

I see what the issue is. Can you please test exporting a PDF locally from your main Grasshopper definition with the WritePDF component? Let me know if that works as expected.

The local pdf export exports well :slight_smile: SquidPrint.pdf (99.9 KB)

I will have to have a closer look at the Grasshopper model then. Could you post the definition which exported the PDF above? (204.8 KB)
Ah, thank you very much! :slight_smile:
I can not post the whole definition, but this is the definition related to pdf/make2d

We have tested the definition you posted and PDF exports work both locally and on ShapeDiver. I’m wondering if the problem is not with Make2D but somewhere else.

Hi again Pavol! Thank you very much for helping out.
And you are right!
I don’t know how the errror happens, but I figured out what made the error.

It was one of the door options. The door had considerably larger polycount, maybe that caused the bug. (choosing another door, than the make2D/pdf-worked)
I rebuilt the mesh of the door, and now it works.

The strange thing is that the definition worked while generating locally, but chrashed while using Shapediver… Anyways: Thanks!

1 Like