Make 2D & clipping Plane

When looking at the clipping plane the model shows a rendered view rather than shaded view?

Also, when using a clipping plane and make 2D the result shows faces but not capped solids as it shows within the viewport:

Andy

@GregArden
Is this on your YouTrack list?

Yes, Its toward the top of the desired features list.

Hi, sorry to revive this fossil thread, but… what the stand on that feature?
It seems that Make2D still handle some edges as ‘Visible’ even if they’re behind the clipping plane…

I do not see the clipping plane graphic in your screenshot.
Please post a file with that geometry.

It’s working as expected here:


Make2D and ClipPlane.3dm (76.3 KB)

Here you go: test_clippingplane.3dm (99.2 KB)

And system info:

Rhino 6 SR18 2019-9-10 (Rhino 6, 6.18.19253.10261, Git hash:master @ 1dbe29bf1545c65abce614153c67ceea87262a12)
License type: Commercial, build 2019-09-10
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: HESWS29

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 7-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.70

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-24-2019
Driver Version: 26.21.14.3170
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.18.19253.10261
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Users…\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Iris (1cd9c8f5-c901-426c-8e80-d6a2e2b18bba)\1.0.6911.20081\Iris.WinR6.rhp “Iris” 1.0.0.0
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Users…\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\ClippingBox (4dfff1df-5f09-43ae-a044-77b115244b02)\1.0.0.0\Rhino 6\ClippingBox.rhp “ClippingBox” 1.0.0.0
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.18.19253.10261
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\cadwork.dir\EXE_25\3d.x64\Rhino Plugins\CadworkTools.rhp “CadworkTools” 1.1.0.0
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.18.19253.10261
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.18.19253.10261
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users…\Downloads\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”

It working fine here.
If I move the clipping plane to clip off more of your box and run Make2D, I get a shorter 2D result:

Ok, but in yours, the ‘inner’ edges appear to be on the ‘hidden’ layer, like if the clipped surface was filled (like cutting a real solid):
image
This is also the behaviour I’m looking for.

In my model, the inner edges are treated as ‘visible’ (like cutting a hull):

I get the same output with your file:


Edges viewed through the clipping plane are considered as visible.

Your linetype scale setting is too small.
In Options > Linetype, change the line type scale to 200 or higher.
Your lines are using the Hidden pattern but your scale is so small you can’t see them.

Humm, not sure it has to deal with linetype, please see here, the selectionned segment is really on the ‘visible’ parent layer:
image

The Hidden linetype pattern is defined as a line 2mm long followed by a gap 2mm long.
Your linetype scale was set to 1.0
The section of hidden line is 15761.85 millimeters long.
Divide that length by 2 and you still have a lot of tiny little dashes you can’t see on your monitor.
Change the LT scale please

I increased the LT scale and I now see dashed lines. Unfortunately it was not my problem. I think there’s misunderstanding in the air :slight_smile:

1 - what I get out of Make2D: inner edges are on the ‘Visible::*’ layers
2 - what I want: all inners edges occulted by the clipping plane to be on the hidden layers:

If you uncheck the Hidden lines option in Make 2D, the the visible surfaces will occlude the surface edges and curves behind them.

3 - the result with unchecked ‘hidden lines’ by Make2D, still hollow representation:

It looks like your Clipping Plane is slicing off the front face of the box in 1 and 3 so you can see the insides.
2 looks wrong to me.

But 2 is exactly what you get in your example:

I had my Perspective view rotated around so the clipped off surface is on the back, away from the current view.

OK, that’s an explanation. So I understand that the original wish of this thread (capped solids while performing Make2D sliced by a clipping plane) have not been implemented yet.