Major Crash Fixed in Rhino 6.5, 6.6, and 7.0 WIP

Hi All,

Today we’ve released three builds of Rhino that fix a crash bug that’s been plaguing Rhino for months. This fix is deep in the core of how Rhino handles strings. This fix is in Rhino with these version numbers or newer:


Rhino should tell you that a new build is available to install sometime in the next few days.

This will fix the following issues:

  • Rhino refusing to save files
  • Crashes when working with dimensions, text, and annotations
  • Some crashes in Grasshopper

Please continue to submit any crash reports you see, and especially let us know if you see problems saving files, or crashes with annotations.




I am sorry to tell that this problem is not fixed… Again, My rhino refuses to save. This time error message shows “Writing to the disk or storage device failed”.
I tried to save it as Rhino 5, it worked, but when i opent it again in Rhino 6, all my text dimensions have changed.


I cannot help with the issue, but can you already also send your systeminfo so the developers know what exact build you are running.

Command: _SystemInfo and paste the text in a post here


Rhino 6 SR5 2018-5-29 (Rhino 6, 6.5.18149.14421, Git hash:master @ 39e73a6a93c18c92e40c05cb323c990246a30569)
Licence type: Commerciale, build 2018-05-29
License details: Cloud Zoo. In use by: 10h10 | Architecture & Urbanisme ()

Windows 10.0 SR0.0 or greater (Physical RAM: 62Gb)
Machine name: PCSARAH

GeForce GTX 970/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 388.13)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-27-2017
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

You have a version previous to the fix. The fixed version is 6.5.18155. Try downloading the latest service release/release candidate and installing.

HTH, --Mitch

1 Like

Allright, thank you !

A post was split to a new topic: Rhino crashing when editing annotation styles

2 posts were split to a new topic: Crash in Rhino 6.11