MAJOR BUG JUST APPEARED RHINO 5 64bit


#1

I have been building banners for a new website with no trouble until today. When I typed out my text as I have been doing for some reason some of the letters are not being applied to the the surface when placed and or the letters are not being completed. This is the sixth or seventh banner I have done so I know that this has been working fine all along.

I opened Rhino 5 32 bit and had no problem doing the same thing. I also opened Rhino 4 and had no problem.

I have attached a screen shot of my results and I am in hopes that someone can be of help on this bug.

I restarted my computer and this had no effect.

All my best … Danny

P.S. I tried this with more than one font. In the screen shot there were two c’s prior to the other four letters


(Pascal Golay) #2

Hi Danny- can you post a screen grab of the command dialog when you run into this?

thanks,

-Pascal


#3

Pascal, Here is a new screen shot. I need to let you know that I just started to work in Rhino 5 32 bit and am getting the same results. Not in Rhino 4 though.

Danny

The command line says select insertion point when I click on the surface there is nothing in the command line


(Pascal Golay) #4

Hi Danny- are there fonts that work and ones that do not? It looks like I do not have Revue BT, but if this fails in a more standard font I can test- meantime, please post an example that did not work- and please also repeat the same text but only as curves, not surfaces or solids.

thanks,

-Pascal


#5

Pascal,
Just did it with times new roman font with the same results.I did this only curves and it works properly. Here is a screen shot using times new roman, again the c’s disappear but the other fonts are proper.

I just tried with about ten other fonts, some work perfectly some give me the same results. All work as curves


(Pascal Golay) #6

Hi Danny- if possible, please post a file with some of your tests that do not work well- curves and solids.

thanks,

-Pascal


#7

Pascal,
Here is the file that I have I am working on that the screen shots are from. I just tried this in another banner file saved for another page and am getting the exact results so it is not only this file.

banner.3dm (1.4 MB)


(Brian James) #8

This looks like a unit issue. Your tolerance is set to .01 inches but at the size of the letters, this is insufficient for the surface trims to work. Change your tolerance in Options>Units to .001 and it should work fine… as it does here.


(Pascal Golay) #9

Hi Danny- everything here looks correct, right? I was hoping for some that were wrong, along with the same text as curves. Meantime, I’d change file tolerance to .001 and see if that helps at all.

-Pascal


#10

Leave it up to Brian, for whatever reason I changed the tolerance earlier today. Changed it back to.001 and this fixed nearly everything, but I am still getting these results with revue no c’s and letters not coming out right. I have been using revue on all of my banners I am attaching this font for you to try., can’t attach the font because it is a .ttf I can email it if you would like

P.S. I have not changed a thing in Rhino 5 32 bit and get the same results. Just started new files in Rhino 4 and things are working fine.


(Brian James) #11

Great, can you send the ttf to tech@mcneel.com please?

One thought in the meantime is to make the C’s bigger and then scale them down. The C’s in the revue font must have some odd control point structure causing the surfaces to not trim at some sizes and unit tolerances. If you can also send the v4 file that works fine and the v5 file that does not that would be good to compare.


#12

Fonts and files are on the way you should already have them. I will try making the c’s larger, but this size is what I have been using for at least six to ten banners with no problem.

Just did the fonts in two inch size, the holes in the B are not there in both 32 and 64 bit with .001 tolerance. All other letters are right the C’s are there.


#13

Brian and Pascal,

After Brian looked at my setup remotely he must have thought I was a bit nuts. I had done a drive image on my computer so he was looking at a pristine Rhino5 64 bit. I opened a file I was having trouble with having forgotten to change the tolerance from .01 back to .001.Well Brian did this and of course things worked properly. I very much enjoyed my visit with Brian and had the opportunity to ask a few questions.

After things seemed to be fine I started to work on my web site banners, I typed the letters for the next banner and again they were not complete. I finally saw what was causing this to happen, for whatever reason I clicked on bold, in doing this it caused the problem. As I did not and do not want the letters in bold I have no clues why I clicked bold.

As I have stated many, many times here and elsewhere I think Rhino is the best of the best for individuals like myself.

All my best … Danny