Magic Mouse pan and rotate


#1

After enabling gestures and enabling scrolling with one finger to pan and rotate views, is it possible to swap between pan and rotate? Mine seems to have swapped from rotate to pan and I can’t find a way of changing it back. An earlier version of the same file still rotates OK with the scroll gesture.


(Marlin Prowell) #2

I understand this.

This is too brief to understand. Could you restate it as, “When I ----------- in the ----------- view, ----------- happens, but I expect ----------- to happen instead.” Fill in the blanks with your descriptions.


#3

Hi Marlin,

Sorry it wasn’t clear - I was trying to keep it brief.

Long version:

While I was updating to the latest version of Rhino, the Magic Mouse batteries ran out , so I swapped to a Wacom tablet. After installing new batteries in the mouse I re-opened the Rhino file I was working on. I found that, working in the perspective window and swiping on the magic mouse, the behaviour had changed from rotate to pan. I checked that the mouse settings were set for enabling gestures and enabling scrolling with one finger to pan and rotate views and they were OK.

I tried deleting the Preferences file and re-opening Rhino, but I could still only pan with the swipe gesture. I checked the Rhino for Mac wiki, Navigating with a Magic Mouse, which tells you how to change the behaviour to pan and rotate from zoom, but doesn’t tell you how to swap from pan to rotate - hence the question.

I finally found in Preferences/View/Rotate that the setting had been changed to Rotate around world axes. Re-setting this to Rotate relative to view seems to have sorted out the problem. I didn’t change the setting accidentally, since I haven’t had any reason to alter the view preferences, so I can only assume that it was something to do with the update or swapping from magic mouse to Wacom tablet and back again.

I hope this makes it clearer. My problem seems to be sorted and I am up and running again.

Best regards,

David