Macro weirdness - latest build

In the December 16 build , my “invert hide” and “invert freeze” macros are lagging - it takes 2 to 3 seconds before it works where in the previous build it was instantaneous.

I haven’t changed the macros and it also happens in a new file with just two single lines in the document. Manually invert hiding happens as fast as I can type “in hi” - which is faster than 3 seconds.

FWIW, the macros are simply:

IF _Invert _Lock
IH _Invert _Hide

Seems to be working normally here… Either using the stock toolbar buttons with those macros or creating a custom alias… --Mitch

Thanks for trying!

Yeah… hate it when that happens…

Well, at least the feedback makes one look further into the user-specific things…

  • RH5 behaves as before.
  • A new file in Serengeti and picking the “Small Objects - Inches” template doesn’t misbehave. :signal_strength:
  • RH5 and Serengeti use the same custom template upon launch.
  • My custom default template includes 3 layouts with 1 detail and a bunch of line and text objects each.
  • Deleting those layouts does not help.
  • Putting the display mode to a standard one (modified wireframe but the settings apply to the application irrespective of template) doesn’t help.

OK, it gets weirder…
Starting a new file with my custom template shows the problem.
Saving, closing, and reopening that file does NOT misbehave. It’s been a long while since I started a new file and so this might be something that has been around for a while.

One more test:
Launching Rhino > New > use my own custom template - No problem. So it doesn’t look like it is template-specific…