Mac OS Sierra (translation problems and slowdowns) WIP 5E12w (solved)

sierra
menu

#1

Yesterday I updated sisema operating in Sierra (Italian). I encountered one difficulty and a problem. The difficulty is that the menus are mixed in English and Italian. The problem however is that so completely random, after selecting a simple command, appears the colored ball spinning for a few seconds and only then appears on command.

Software information

Software versions
Rhinoceros version: 5.4 WIP (5E12w)
IronPython version: 5.1.2015.131
WIP expiration: 11 marzo 2017
Language: it-IT (MacOS default)
macOS version: Versione 10.12.3 (Build 16D32)

Plug-ins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient

Third party kernel extensions
com.logitech.manager.kernel.driver (6.40.1) C1D41FB7-7A01-38E3-A769-65B1DE65B0FD
com.3dconnexion.driver (10.4.3) CDD8E81B-F6DA-3673-B781-9AB464363E29
com.kairos.driver.DuetDisplay (2) ACE0314B-69A7-3100-9155-3B4B6C96B2EC

Hardware information

Computer hardware
Hardware model: iMac13,2
Processor: Intel Core i5-3470 CPU @ 3.20GHz
Memory: 32 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GTX 680MX 2048 MB
Memory: 2048 MB
Screen size: 2560 x 1440
Displays: iMac (109dpi 1x)

USB devices
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)
Inateck USB to SATA3 Bridge: Inateck Generic USB Device
Lexar: WorkflowD512
TOSHIBA: External USB 3.0
3Dconnexion: SpaceMouse Pro

Bluetooth devices
Sconosciuto:
Apple: Apple Wireless Keyboard
Apple: Apple Wireless Trackpad

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.14.20 355.10.05.15f03
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bit
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: Yes

Appearance settings
Antialiasing: 2x
Mip map filtering: None
Anisotropic filtering: None


(Dan Belcher) #2

Not sure about the slowdowns. As for the localization (translation) problem, please let us know what your Rhinoceros > Preferences > Language setting is. I’d wager that it’s “Use macOS language setting.” If so, please set it to Italian explicitly. We have a bug on our list related to this issue.


#3

Great. Setting the language explicitly the problem seems solved.
As for delays, decreased by deactivating the option to System Preferences> Power> put in stop the hard disks when you can.