Mac Grasshopper scroll-wheel zoom is opposite Rhino

This appears to be a regression from Rhino 6 for Mac… The scroll-wheel zoom direction in Grasshopper for Rhino 7 is opposite the direction set in Rhino’s view prefs. If I set the zoom scale factor to 1.1, GH is reversed and behaves as though the value is < 1.0. If I then set the scale factor to 0.9, GH reverses and behaves as though the value is > 1.0.

Bumping…I just got Rhino 7 and have the same issue.

Is this on someone’s radar at the home office?

Same here on Mac for Rhino7 v7.5, …whatever is Rhino Zoom factor, GH is the opposite.

Ok, don’t ask me why, but if I enter a negative value to my zoom scale factor in Rhino, then GH behaves the same for zooming, cool :wink:

@dogrocket and @brock you may want to try this on your machine?

1 Like

nice @Balazs_Kisfali, well the negative value only inverts the Rhino zoom direction, but with this, both Rhino and GH have a wrong zoom direction…

@dan any news with the Grasshopper zoom direction?

It was always madness to get used to the workflow of each platform again and again with the scroll-wheel zoom and the way to delete components(because of Bootcamp).

Related to WINDOWS Bootcamp, Rhino use backspace key as delete by default, but on grasshopper we need the fn key to delete. Maybe is just to allow the backspace key on the edit shortcuts please. @DavidRutten.

Sorry for the delayed reply. I presume you mean this issue:

RH-36624 Grasshopper: Preference to inherit/lock scroll-wheel zoom to Rhino’s settings

No progress, unfortunately. (You can star the issue on YouTrack to get updates when it budges.)

I don’t recall why this happens for some people (my memory is fuzzy, so I think someone could fill me in again), because delete works just fine in Grasshopper in Rhino for Mac (7.7). No need to hold down the fn key here…or maybe I’m misunderstanding, you’re talking about Rhino for Windows in Bootcamp using a Mac keyboard?

Thank you @dan for your response, Related to the zoom direction. I temporarily fixed it by first changing the scroll to “unnatural” with scrollreverser (To fix the GH direction), Then in Rhino using the scale Factor -1.1.
With this, GH, Rhino and all the device have the same scroll direction as Windows.

Yes, this is a windows issue with a mac device, why edit shortcuts don’t allow to use of this key?

The opposite happens on grasshopper for mac too.