Lowest screen type

In Mac is retina the lowest resolution to run rhino 8?




This iMac has NOT retina…

Hej Mikael -
In Rhino, please run the SystemInfo command and copy-paste the output here.
-wim

Rhino 8 SR4 2024-2-13 (Rhino 8, 8.4.24044.15002, Git hash:master @ 5d3f86ffffae3c2ed84d21147c008b3907a40a2e)
License type: Evaluation, build 2024-02-13
License details: Cloud Zoo
Expires on: 4686875-01-17

Apple macOS Version 14.3.1 (Build 23D60) (Physical RAM: 8GB)
Mac Model Identifier: iMac13,1
Language: sv-SE (MacOS default)
.NET 7.0.0

Metal GPU Family Apple 0
Metal GPU Family Common 2
Metal GPU Family Mac 1
Graphics processors
NVIDIA GeForce GT 640M (512 MB)
iMac (1920 x 1080)

USB devices
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: Apple Keyboard
Apple Inc.: FaceTime HD Camera (Built-in)
USB 3.0 Device: USB 3.0 Device

Bluetooth devices
None

Third party kernel extensions
as.vit9696.Lilu (1.6.7) 087C34D2-49F8-3FDA-8757-27E9425C9EE4
as.vit9696.RestrictEvents (1.1.3) BD2EAC64-2586-3695-AA58-72255A9AECC7
com.khronokernel.FeatureUnlock (1.1.5) 3BC0E8D8-1F4C-327D-A644-3A7A1A4B77A9
as.acidanthera.BlueToolFixup (2.6.8) F79E90EC-E91C-3D93-83D1-C0C5C9206285
com.khronokernel.AutoPkgInstaller (1.0.3) EDB46935-7CC0-335F-88E1-6FEEEBCCC7E9
com.khronokernel.CryptexFixup (1.0.2) 23DAEDA6-F411-3F65-B96D-E64E3286697D
com.flagers.KDKlessWorkaround (1.0.0) E964DA93-FAE8-33A6-9B27-98A788A4029E
com.khronokernel.RSRHelper (1.0.0) 405DAFD6-7D78-3D88-B9FB-2219DE151AE7
as.lvs1974.AirportBrcmFixup (2.1.8) 515DB8CD-0B41-3743-92EE-10708B706080
com.dhinakg.AMFIPass (1.4.0) 919CD3B3-83DF-333E-99A2-00433847489A

Third party plugins
/usr/lib/swift/libswiftCoreGraphics.dylib
/usr/lib/swift/libswiftCoreImage.dylib
/usr/lib/swift/libswiftMetal.dylib
/usr/lib/swift/libswiftQuartzCore.dylib
/usr/lib/swift/libswiftCore.dylib
/usr/lib/swift/libswiftCoreFoundation.dylib
/usr/lib/swift/libswiftDarwin.dylib
/usr/lib/swift/libswiftDispatch.dylib
/usr/lib/swift/libswiftIOKit.dylib
/usr/lib/swift/libswiftObjectiveC.dylib
/usr/lib/swift/libswiftXPC.dylib
/usr/lib/swift/libswift_Concurrency.dylib
/usr/lib/swift/libswift_StringProcessing.dylib
/usr/lib/swift/libswiftos.dylib
/usr/lib/swift/libswift_RegexParser.dylib
/usr/lib/swift/libswiftsimd.dylib
/usr/lib/swift/libswiftUniformTypeIdentifiers.dylib
/usr/lib/swift/libswiftOSLog.dylib
/usr/lib/swift/libswiftCryptoTokenKit.dylib
/usr/lib/usd/libusd_ms.dylib
/usr/lib/swift/libswiftCoreAudio.dylib
/usr/lib/swift/libswiftCoreLocation.dylib
/usr/lib/swift/libswiftCoreMedia.dylib
/usr/lib/swift/libswiftCompression.dylib
/usr/lib/swift/libswiftCoreMIDI.dylib
/usr/lib/swift/libswiftAVFoundation.dylib
/usr/lib/swift/libswiftCoreML.dylib
/usr/lib/swift/libswiftFileProvider.dylib
/usr/lib/swift/libswiftIntents.dylib
/usr/lib/swift/libswiftAccelerate.dylib
/usr/lib/swift/libswiftGLKit.dylib
/usr/lib/swift/libswiftGameplayKit.dylib
/usr/lib/swift/libswiftMetalKit.dylib
/usr/lib/swift/libswiftModelIO.dylib
/usr/lib/swift/libswiftSceneKit.dylib
/usr/lib/swift/libswiftSpriteKit.dylib
/usr/lib/swift/libswiftVision.dylib
/usr/lib/swift/libswiftRegexBuilder.dylib
/usr/lib/swift/libswiftDemangle.dylib
/usr/lib/swift/libswiftVideoToolbox.dylib
/usr/lib/swift/libswiftObservation.dylib
/usr/lib/swift/libswiftWebKit.dylib
/usr/lib/swift/libswiftNaturalLanguage.dylib
/usr/lib/swift/libswiftSystem.dylib
/usr/lib/swift/libswiftMapKit.dylib
/usr/lib/log/liblog_network.dylib

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino 8.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 8.4.24044.1002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 8.4.24044.15002
/Applications/Rhino 8.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 8.4.24044.1002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 8.4.24044.15002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/MeshCommands.rhp “MeshCommands” 8.4.24044.15002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 8.4.24044.15002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 8.4.24044.15002
/Applications/Rhino 8.app/Contents/PlugIns/SectionTools.rhp “SectionTools” 8.4.24044.1002
/Applications/Rhino 8.app/Contents/PlugIns/Displacement.rhp “Displacement” 8.4.24044.1002
/Applications/Rhino 8.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 8.4.24044.1002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 8.4.24044.15002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 8.4.24044.15002
/Applications/Rhino 8.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCodePlugin.rhp “RhinoCodePlugin” 8.4.24044.15002

I can not get to write any command In rhino since it won’t start upp at all. Look at movie.

Bilagan tillgänglig fram till 1 apr. 2024

I hope the movie can be seen this time
/Mike
1 mars 2024 kl. 14:44 skrevKlicka för att hämta

IMG_2995.mov
77,6 MB

Wim D

ekeyser via McNeel Forum <notifications@mcneel.discoursemail.com>:

Hi Mikael-

I would not expect Rhino 8 for Mac to run on this decade old iMac. According to EveryMac, the maximum macOS version on this iMac is 10.15.*, which I OS X Catalina: iMac "Core i3" 3.3 21.5" (Early 2013) Specs (Early 2013 (Edu), ME699LL/A, iMac13,1, A1418, 2545): EveryMac.com

The reason for our minimum requirement of macOS Monterey in Rhino 8 is that nearly all Macs that run Monterey ought to support Apple Metal, which is the display technology in Rhino 8.

Somehow you’ve managed to get macOS Sonoma on this iMac. I have no idea how…but I imagine that some of the many third-party kernel extensions you have installed were necessary.

As always, you are welcome to return Rhino for a full refund (if you ended up purchasing - looks like you have an evaluation version). Please contact your dealer or visit www.rhino3d.com/sales to contact McNeel in your region.

I can help clarify that bit.

From the looks of things this is an OpenCore Legacy Patcher system, the “core” lf which is based on OpenCore which is an EFI bootloader (originally used to be able to cross boot windows and various linux distros from an EFI bootpicker) but the OCLP folks go well beyond that and sorta hack around the stuff in more current versions of the OS to get things to “run”.

While it enables the base os to boot, there’s stuff in Sonoma and and everything beyond that use instruction set stuff (AVX calls being one) on the intel procs and the metal graphics cards that weren’t present in the chipsets the older stuff shipped with. And it kinda sorta works, unless your running graphics intensive (AKA CAD apps) that make calls that use the instruction set stuff not present in the chips themselves.

Now I run “pure” OpenCore on my 2010 towers and the key difference between “pure” OpenCore and OCLP is that they use all Apple’s actual kexts and just remap where the OS finds them for calling purposes, but that only gets you part of the way there. However to NOT run into issues, you have to get a current gen Bluetooth card, have an NVME drive, and an actual real metal card that supports the GPU calls that OSX uses (AKA a Radeon RX580, and a very few select others).

Finally you have to rebuild your bootrom firmware to get all that stuff supported, which is way beyond most folks capabilities.

There is an ex Apple FW engineer that does this as a service though, and it also cures the NVRam tailless buffers from stomping on themselves and bricking your motherboard (the older NV ram wasn’t really set up for storing stuff like iCloud account and keychain info and a raft of other stuff.

At the end of the day it’s a lot of work to do but DOES enable you to get a full on bona fide OSX running from Mojave all the way through Monterey, but no farther, as past that point the OS requires hardware instruction set stuff that just isn’t present in the older HW.

However doing “true” Open Core does require you manually setup all the parameters which takes a fair bit of doing as the various Apple machines over the years had all kinds of different FW builds, 3rd party chipsets and other “stuff” and you have to put all that into the boot loader for this to work, and it’s a fairly tedious process.

Once that’s all done you can literally run the stock apple installer for any of those OSX versions, do over the air upgrades and everything else as it’s not a hacked version of the OS like OCLP is.

It works, it works astoundingly well (I run Rhino / Fusion / PrusaSlicer, Parallels, Logic / Mathmatica and even AutoCad for when I need to work with customer provided CAD that has full on dynamic blocks, and a raft of industry specific DSP programming apps that tend to be really fussbudgety about a very clean os, and I went down this road as up until recently Rhino didn’t work to well with Apple Silcone, and some of my industry apps STILL don’t work at ALL on Apple Silicone.

An opencore (not to be confused with OCLP) install will look like:

as.vit9696.Lilu (1.6.2) 264B15BE-8923-3A33-A9F5-8F0FFBB80595
as.vit9696.WhateverGreen (1.6.3) 9599C0FC-6144-3136-854C-C15FFF63706F
com.khronokernel.FeatureUnlock (1.1.2) 46C7C044-AE43-378A-8E50-F24BA68705DA

The Lilu kext handles the.OSX library mapping stuff, the Whatevergreen maps the OSX to the metal GPUS (as they weren’t present in the initial hardware) and FeatureUnlock handles the mapping to the “current” BlueTooth stuff and enables sidecar, nightshift, Airplay and Universal Control.

Hope that’s helpful.

2 Likes

Yes, thank U; very much so.
/Mike