Low res display

Nevermind. Turns out I had turned on flat shading. No idea what the benefit of this setting is supposed to be.

So you can see the actual mesh facets without the smoothing that obscures them.
It’s critically important when cleaning up crappy meshes.

1 Like

But I’m using NURBS, not meshes. So why should I care what a mesh looks like for a NURBS model? Or am I not understanding how Rhino deals with 3-D CAD data?

In order to be able to see the NURBS on screen, Rhino has to create a display mesh. This means that you do care about the mesh settings in the document properties.

Should you care about flat shading? As long as you stay in NURBS and don’t have to export to a mesh file format, probably not. That doesn’t mean others don’t need this setting…

I don’t intend to do any meshing in the near future, no. I appreciate the need for it when working with meshes but I do not understand then why it should be in the view settings section which coveres both NURBS and meshes and takes a great number of clicks to get to when it could simply be a toggle with a hotkey like points on/points off or grid on/grid off, etc. That, to me, would be a logical UX design choice rather than deep in the view settings menu. Thanks for your reply.

Because it is a view setting (it removes smoothing tricks from the view) and because you cannot see NURBS surfaces without meshing.

You don’t need to click at all. You can just type flatshade to toggle this setting. If that is something that you need to do a lot, just assign it to a shortcut…