Losing track of textures located in the file's folder


#1

I have a library of products that I am trying to set up so that others in the office can do simple renderings themselves. I created a “master” file(and these are all on a network location) that has the environment setup and material choices, and people can just drag-and-drop the products and change their colours and hit render. Simple right? No, because even though the master file is set to pack textures–and there only are FOUR needed–I tested it out today on my other machine, and it lost track of all the textures and rendered the scene(I guess because of the light dome) all black. When I hit render and the lost textures dialog popped up, and manually located the textures, it still failed to actually use them. It worked alright when I tested it out on my machine at home, with my backup of my work folders on a USB disk.

This is an incredibly frustrating cluster-something and I need a bulletproof solution within the next two weeks, having that happen when trying to demo this to my coworkers was NOT FUN.


#2

A clue…funny thing, while trying to use these files on my second desktop (which can access shared folders on the main one)this is a total mess, while at least the first test having another user Remote Desktop to the same machine, it worked okay, as when from home. It’s like when using it on my profile it’s finding the textures in more than one place and keep straight which one to use.

On opening up the “master” file, there’s a background texture that is visible in Neon, but if I switch out of Neon and back, it disappears, and does not render…I just tested if it only loses track of the texture for Brazil after I toggle Neon and no, as soon as I import a product(and they do have some materials of their own)all goes to crap.

Edit…I copied all the texture files to the scene folder, and no luck, my second machine could not find them, and manually locating them in the missing textures dialog did not work. EDIT…to get it to finally work (so far)I had to in addition to copying the textures to the scene folder make sure the textures in the master file were all pointing to them.


(Brian James) #3

Can you provide us with the Master file and the textures used as well as a product to import into that scene? I can try and mock this up but want to make sure I have the exact same situation here. Please also include the specific steps taken to show the issue and a copy of what the render result should be. I will need to reproduce this here in the simplest manner possible before filing a bug report for development to look into. Here’s my guess at the steps so far…

  • Open Master file from a private network location.
  • Test Render using Neon with Brazil as the active engine (the result should be correct, i.e. with texture maps)
  • Import a new 3dm into the open Master file from the same network location
  • Render again using Neon (the result is missing texture maps)

Is that correct? Please send the files to me privately if they are confidential and I’ll try to help more.


#4

I have this problem with V-Ray as well. What can complicate matters even further is when the 3D file is opened AND the texture directory is not visible, like when you are not in the office or the server with maps is turned off / re-booting / etc. I have even seen materials ‘get disconnected’ if they can’t be found and the 3D file is saved before you notice.

My ‘work-around’ is to copy all textures needed and place them in the same folder as the 3D file. This method does not address your office workflow needs, but it does work every time. One added benefit is that you can move the project folder anywhere and all materials will work anywhere you go.


#5

Yeah that’s what I’ll have to do…though seemingly just copying the textures wasn’t enough, I had to point all the materials to those textures. And crazy enough it’s only one machine that actually has the problem! Ugh.


#6

Hi Brian,

I’m sending you some files now, there is a BAK of the scene file from before the move-to-same-folder fix. The textures(minus a couple not actually used) are included but they are also supposed to be packed, so try to not actually use them.

The procedure was:

-Open the ‘master file,’ which has neon activated by default.
-Drag-and-drop import product files
-brazil render fails to find textures, even if located in master file folder(without reassigning the textures,) even if I tell it where to find them in the lost textures dialog

This problem only seems to occur in my profile on my secondary desktop, which unlike someone else using it via remote desktop, has a saved library connecting to the folders on my main desktop where the textures in those files originally resided.


(Brian James) #7

Thanks for the files Jim. I have not been able to reproduce your problem here so far. I will see if @andy has any ideas but at the moment my best guess is that this is due to some network setting or firewall on the one machine where the textures are not found. I have tried importing them separately via Import as well as dragging and dropping both files in unison. In both scenarios, the textures are located in the extracted folder on the network as expected.


(Andrew le Bihan) #8

Try typing TestUseRDKFileFinder at the command prompt. Does this fix it?

  • Andy

#9

Hi Andy,

Not with this file on that workstation, no.


(Andrew le Bihan) #10

I would like to investigate this further. Would you be available for a remote control session?


#11

Today yet? Yes if IT help wouldn’t be needed to get it working.


#12

So to anyone reading we don’t know for sure yet but there’s a chance that this (and maybe some other issues come to think of it)may be something wonky going on with server file permissions.