Lofting Separate Sets of Curves


How can I use grasshopper to not have these spacing between the lofted surfaces? There are 4 separate sets of lofts, I tried “Reverse” opetion on loft C input but to no avail.

Another problem is this? how come my loft surface is separate from the curves? It is much smaller and if I want to bake the geometry surface for fab, the dimensions will be totally off: (153.4 KB)

2019-04-28-Complete.3dm (3.4 MB)

  • you uploaded a rhino file only- you might need to post a grasshopper file too.

Did you check in the loft options within the loft component when lofting the curves? Make sure ‘rebuild’ isn’t selected unless you give it a high enough point count to approximate the curves. A loft using ‘normal’ or ‘tight’ or ‘uniform’ should work fine.

For lofting all curves in a continuous surface you need to grab all curves and sort them vertically in a list so it works

Looks like you’ve only used first and last curve for your loft operation.

Oops, I posted the gH file as well.
I actually did try those loft options, but not getting a loft that goes in between the empty spaces…

Thank you, it solved my second problem - but the first pic / problem still remains…:pray:

Check this. Not sure this is what you are after.
For the solid union operation to work, try to change your rhino file’s unit tolerance from 0 to 0.01. (111.4 KB)
2019-04-28-Complete_re.3dm (3.7 MB)


Thank you! Your help is making me learn so much - I really appreciate it! :black_heart: