Lofting behaviour

I’m having an issue with a loft that I can’t figure out. I’ve checked the direction of all the curves used and they’re the same. I’ve not experienced this problem before and I don’t know how to solve it.

the problem seems to be the first largest curve. I need to loft all four at once.

MatchedSurf.3dm (1.4 MB)

@JKayten Does sweeping 2 rails give you the result you are after?

edit: loft gave me this

I’d just do this in 5 separate lofts. The ‘fillet’ bits look cleanest with the Refit setting in Loft, .1.

My guess is the problem lies in the little ‘fillet’ curves - they do not combine very well. I made a script,
currently Windows only I’m afraid, for making clean ‘fillets’ between non co-planar curves - with those, the joined version lofts cleanly, Though, I’d still be inclined to make separate surfaces.
FilletNonPlanar, here - I’ll see if I can Pythonize it for use on the mac.