Lofted Plate not displayed in Tekla

Hello, I am new to Tekla-Grasshopper live link. I am trying to create steel plates in Tekla with varied height and it was suggested to me to create lofted plates for such cases.
I managed to create horizontal plate, however when I am modelling vertical plate with inclination, Tekla does not display the graphics of the plate and I am not sure where I have a mistake in my script.
I would appreciate your help!

Lofted Plate.gh (21.8 KB)

Hi,

It seems that your plate is planar so you could simply use the plate component with the boundary as input.


But if you want to use the lofted place component you have to make sure that the direction of your curves are the same. In the below image I flipped one of them and it works a treat.

1 Like

Thank you so much for the insight Oskar! This worked.
Now I have the same issue for my horizontal plate. The surface is not planar.
I think the problem might be not constant width of the plate, but I am not sure. Is there a way to fix this?
Lofted Plate-2.gh (11.3 KB)

The curves need to be a part of the same branch… in this case i just flattened them

Oskar,
The two components that are not shown in your script put both curves in the same branch:

Even with flattening, as you suggested, does not work for my script…

Hi MCikhra,

Lofted plates can be sensitive to the geometry of the input curves. Unfortunately I don’t think the situation will improve in the near future. Some observations here:

In addition to the interpolate option in the above thread I noticed that with your curves you could use the Rebuild Curve component with a Count input of 6 to give you something that Tekla likes. But that only works in this particular case and isn’t a general solution.

Cheers,

-b

1 Like

Hi Sebastian Lindholm,
Thank you for your response!

I have tried interpolate curve from the other thread before; however, interpolation would not be the optimal solution for my goal.
I can also create series of planar surfaces (in this case 3 segments) as simple plates; however Tekla recognizes them as 3 different plates and connection between them is also not ideal. Is there a way to combine these plates as one or “trim/extend” the ends of plates so they fit the end edges?

Also, would it be possible to create more reliable lofted plate with Tekla API code in grasshopper?

Thanks.

You could connect them as a bent plate if that’s an option, at least in this case that seems to work fine:

Script here:

Lofted Plate-2.gh (20.6 KB)

The API doesn’t allow you to address shortcomings of the lofted plates I’m afraid, it goes deeper than that.

Cheers,

-b