Locking Texture Scaling

rhino5
texturemapping

#1

I moved from Rhino 4 and Flamingo 2.0 to Rhino 5 and Flamingo nXt and every time I modify a surface or solid (by either scaling it or stretching it), the texture mapping follows the same scale and scaling. This didn’t happen in Rhino4.
Is there an option to set by default that the map should be unlinked from the surface it is applied to, so that if the surface/solid is modified, the texture on it remains the same (if the tile is 1x1mm, it remains 1x1 when the object is modified)?
Having to use the “match” command every time is not an option.
Thank you!


(Pascal Golay) #2

Hi Camillo - set the texture for the material to use the WCS mapping:

image

Does that do it?

-Pascal


#3

Hi Pascal,
Thank you for getting back to me.
How do I get to that panel?
I don’t see it under texture nor mapping of the material, and a search for “WCS” in Rhino’s help returns nothing.
I’m using a simple procedural base material (Black with some sandpaper bump):


and add a .bmp in the texture to create a transparency pattern for a hexagonal perforated sheet metal:
image
An additional annoying thing is that now Rhino doesn’t report the name of the bitmap image used anymore, but it gives it a “Flamingo XYZ” name:

I don’t seem to get any panel listing WCS as an option.
The result is what I need, but when I stretch the object, the texture is stretched as well.


(Pascal Golay) #4

Hi Camillo- I tested in nXt5 ( see https://www.rhino3d.com/store/upgrade/flamingo/nxt ) In 5, the controls show in the Texture panel (Panels menu > Texture palette) when a texture is selected.

-Pascal