Locking Solver when recovering gh files with a 4k monitor

Hi everyone!!

There seems to be a problem when using 4k monitors where you cannot lock the solver when recovering a grasshopper file.

Been lurking for a solution other than changing the resolution of my monitor back and forth and couldnt find it.

Does anyone else have this problem?

No. I’ve done this many times with no problem. I have 2 monitors - primary is 4K 3840x2160, secondary is 1200x1920. I put GH on primary, Rhino on secondary (essentially just for viewing.) My steps for this situation are

  1. Initiate an operation from GH that will run for an eternity.
  2. Exit Rhino or end it with Task Manager
  3. Restart Rhino/GH
  4. Lock GH Solver
  5. From an open File Manager window drag top level recovery file onto GH window
    6 Unlock Solver and it will sit there showing the status of the GH script just before the change that initiated the never ending/long running calculation.

I’m running a PC - if you are on a Mac I can’t say if this method will work for you or not.

So what you mean is that you have a workaround but you actually encounter this same issue, right?

There is usually a tick box (pointed where painted in this new pic) where you can lock the solver before the autosave gets openned.

Thank you very much!

Well…I never encountered the problem you described so I don’t really know if my method is a work around or not. I’ve been using the method I described for a long time, even before I got the 4k monitor. So I never actually saw the problem you described. I do know that it is not unusual for me to make a change to a GH script that results in a never ending loop, which is how I came to develop the method in the first place.

Can you make a sample GH file that you know causes the problem? I’d be willing to test it on my system if you can do that.

1 Like

Hi again!
Grasshoppers automatic file recovery pop up always appears cropped after crashing in my pc (no matter how many times i reinstall rhino) but i am attaching a file that will crash the pc for sure!

Thanks in advance
test solver.gh (515.0 KB)

Yup - after enabling the Geo and Vec components I tried enabling the Exposure one. That started what appeared to be an endless loop, so I ended Rhino. When I restarted everything the GH Autosave directory was empty.

It’s unclear to me what this proves (I have no idea what Exposure is supposed to do) - but the geometry in Geo is interesting.

Hehe, that was some random geometry with vectors to crash the computer. The thing is if you dont go to the GH Autosave directory but instead open a new instance of rhino and then grasshopper, you should be prompted with the lock solver button we were talking about up there!

But i’ve been using your method since then, it is just that i find it sad to have an option to lock solver before a recovery file gets open but being unable to use it and then have to resort to your method instead ;((

But still thanks for yor help Birk!