LoadPlugin cannot be called while a plug-in is being loaded


#1

I am seeing this error when I attempt to use a custom Rhino skin. This occurs both with my own custom skin and the example skin provided on github.


(Dale Fugier) #2

Hi Kevin,

Is your skin doing anything other than setting the application name, icon, and displaying a splash screen? If so, then that is the problem…

– Dale


#3

No. That’s what I initially thought too, because I had been overriding the Skin class methods to provide progress info in my custom skin. It was working on my development machine just fine, but users report seeing this error. I was finally able to reproduce this is a clean VM, but still am not sure what is causing the problem. I have matched the exact .NET version 4.6.1 I have on my development machine, but still get the error in the clean VM. Even commenting out everything besides the app name and icon results in this error message.


(Dale Fugier) #4

Do you have a custom plug-in that is also loading when Rhino loads? If so, could it be that the plug-in is doing something which forces another plug-in to load, such as running a plug-in command?


(Dale Fugier) #5

I guess I’m asking if you’re sure this message is coming from your skin, which I doubt…


#6

Yes, I am also loading a custom plugin. I don’t believe that I am calling any commands when it loads up. Even if I disable the plugin altogether I still get the error.

It appears to be coming from the Skin. The title of the error box is - “App Name PlugInManager Loading Error” .

The error message only goes away if I disable the Skin. I can load Rhino just fine with the Skin disabled and my plugin enabled.


(Dale Fugier) #7

Hi Kevin,

Without any code, I won’t able to provide any more help than I already have.

– Dale


#8

This happens with your example you posted on github. I only get this error in a production environment (no visual studio, etc) .


(Dale Fugier) #9

I was just in the my GitHub sample project today and I was not getting the error you are reporting.

https://github.com/dalefugier/SampleCsSkin


#10

Okay. If you find time, try using your skin on a clean windows installation with Rhino (No visual studio). If you already did that and it still works, not sure where to go from here. This is the only way I am able to reproduce the issue. The skin works fine on the machine I build it on.

Thanks for your help.


#11

Solved. Rhino only gives this error while in evaluation mode. Activating Rhino license avoids this problem.