Loading Time Switching Viewports

I’ve been on V6 for awhile now and I’ve continued to have this problem. When I switch to the perspective view or from perspective view to another view there is an unusually long loading time. It is starting to really slow my workflow down as I jump from view to view quite often. I keep thinking this will get fixed with a new update, but it hasn’t happened. Has this happened to anyone else?

If you have a big model and not so “big” hardware this is normal. Instead of switching why not cread additional viewport(s) set on the different modes you want?

This is happening even when I have all viewports visible. Just clicking from one to another creates a unusually large loading time. This is happening regardless of file size as well. I’m using some pretty good hardware as well so this is another reason I think it may be a bug.

Do you mean you first have Top active, then click in i.e. Perspective?

If so probably a good idea to post the results of the Rhino command _SystemInfo

Yes exactly. It will occur with all viewports open. I am also wondering if it is possibly a problem with the monitors/docking station we are provided with at work. It has caused issues with adobe Illustrator so maybe it is also causing problems with Rhino.

Here is the _SystemInfo

Rhino 6 SR9 2018-9-28 (Rhino 6, 6.9.18271.20591, Git hash:master @ 4cf7435f08f51c972347c8558d28355cfc0471ca)
Licence type: Commercial, build 2018-09-28
License details: Cloud Zoo. In use by: Matthew Catagnus ()

Windows 7 SP1 (Physical RAM: 32Gb)
Machine name: USCAN7N5055

Quadro K2100M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 354.42)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 10-27-2015
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Users\Public\Design&Develop\Rhino6\JPatternPlugin.Rhino6.rhp “JPatternTech”
C:\Users\catagmat\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Voxel8RhinoPlugin (23e7dd63-94e9-4b18-9daf-8f46cd6fd78a)\\Voxel8RhinoPlugin.rhp “Voxel8RhinoPlugin”
C:\Users\catagmat\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\KeyShot7RhinoPlugin (486807a0-d332-4669-8086-e0497d91acd5)\\KeyShot7RhinoPlugin\Rhino 5.0\x64\KeyShot7RhinoPlugin.rhp “KeyShot7RhinoPlugin”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\catagmat\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2017.11.17.800\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Import_PDF.rhp “PDFReader”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello- the first thing to try is to update the video card drivers and see if that does anything good… those are getting to be a little elderly.


Yes that seems a fair bit old. I’ll talk to our IT team about getting these updated and I’ll post with the results.

If updating the driver doesn’t do it try disabling all plug-ins that do not ship with Rhino: Tools » Options » Plug-ins, select from filter drop down the entry for plug-ins that do not ship with Rhino and load-protect them all, then restart Rhino.

Ok so yesterday I was able to get my Video card driver updated and it seemed to fix the problem. I think there is also a problem with the docking stations that interface with our monitors and laptops so that was also contributing to it. Thank you all for the help.