Loading Grasshopper causes Revit fatal error

I can open Rhino Inside Revit but when I try to open Grasshopper I get a fatal error and everything shuts down (Revit included). I’ve tried uninstalling and re-installing both Rhino and Rhino Inside.

The log file on my desktop contains the following:

[ERROR] FATAL UNHANDLED EXCEPTION: System.IO.FileNotFoundException: Could not find file 'Grasshopper.resources'.
   at System.Reflection.RuntimeAssembly.InternalGetSatelliteAssembly(String name, CultureInfo culture, Version version, Boolean throwOnFileNotFound, StackCrawlMark& stackMark)
   at System.Resources.ManifestBasedResourceGroveler.GetSatelliteAssembly(CultureInfo lookForCulture, StackCrawlMark& stackMark)
   at System.Resources.ManifestBasedResourceGroveler.GrovelForResourceSet(CultureInfo culture, Dictionary`2 localResourceSets, Boolean tryParents, Boolean createIfNotExists, StackCrawlMark& stackMark)
   at System.Resources.ResourceManager.InternalGetResourceSet(CultureInfo requestedCulture, Boolean createIfNotExists, Boolean tryParents, StackCrawlMark& stackMark)
   at System.Resources.ResourceManager.InternalGetResourceSet(CultureInfo culture, Boolean createIfNotExists, Boolean tryParents)
   at System.Resources.ResourceManager.GetObject(String name, CultureInfo culture, Boolean wrapUnmanagedMemStream)
   at Grasshopper.My.Resources.Res_CanvasToolbar.get_OpenFile_24x24()
   at Grasshopper.GUI.GH_DocumentEditor.InitializeComponent()
   at Grasshopper.GUI.GH_DocumentEditor..ctor()
   at Grasshopper.Plugin.Commands.ShowGrasshopperEditor(Boolean showUponLoad, Boolean repairPosition)
   at RhinoInside.Revit.GH.Guest.ShowEditor()
   at RhinoInside.Revit.GH.Guest.<ShowEditorAsync>d__12.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

Version info:

Rhino.Inside Revit: 0.0.7622.9729 (13/11/2020 5:24:18 AM)

Rhino: 7.0.20314.03001 (Rhino 7)
Revit: 2021.2 (

@michael.dunn Would you mind taking a look at this release note and download/install the latest versions of Rhino and RIR? I want to see if the recent updates have solved this issue or not


No, I still have the same issue. Log file contents generated are exactly the same.

Rhino.Inside Revit: 0.0.7683.14089 (13/01/2021 7:49:38 AM)

Rhino: 7.1.20343.09491 (Rhino 7)
Revit: 2021.2 (

I don’t have that long left on my trial but kind of need to know this will be resolved before going ahead with a purchase, thank you.

Ok I have forwarded this to @kike as well. I’m sure we can get it fixed

1 Like

Kike helped me out - it was a clash with another add-in. Unitize by matterlab. I’ve uninstalled the offending add-in and Grasshopper now opens.

1 Like

:smiley: I’m gonna say “Offensive Addons” instead of “Conflicting Addons” from now on :sweat_smile:

1 Like