List problem

Hi All,
happy new year to everyone.

I have come to a list problem: Often I get lists where all the item have the same index 0.
In the attached file I have points I wanted to use for a dimension.
The 12 points come as a list with 6 having index 0 and 6 having index 1.
How do I select one by one or how to create a list with seperate indexies for each item?
Can one explain me the sense of having a list with items all of the same index?

Data should be internalised.

Cross section with (800.2 KB)

Hi @BauerNaval,

Are you sure that you are talking about lists, or trees?

Here’s the difference:

Try grafting, as shown in my example, to treat list items separately.
Unfortunately, I can’t open your file, since I’m still working with an older Grasshopper version.

thanks, that might help.
I was talking about List indices. Often it works to select edges or points, but also often it doesn’t for similar cases.
Attached a part where shattering of an circle worked, with same method the 2nd circle stays closed and 2 closed circles appear in the list.

  1. What’s wrong with the shatter of the 2nd circle?
  2. In the list the 2 items appear with index 0. Why’s that and how to change that. Will it be different when the shatter command works correctly? For the other circle it worked that way.

It seems not possible to save the gh-file to an older version?

Thanks (18.0 KB)

At least a screenshot.
The shatter command left of large panel didn’t work while the one at lower edge works fine.

I was not able to follow, your values for x,y coordinates are very large. A good rule of thumb is to start with small values near the x.y.z origins.
That said, I think that you need to flatten your input to the shatter component

this is taken from a large 100+ m ship, the coordinates are just where they need to be.
Learning by doing…
But flattening helped, still need to check out many functions.