Lisence for other device


#1

I am having trouble starting Rhino 6 on my laptop.
I work with the commercial version
.Version Rhino 5 runs without problems on it.But because Rhino 6 is not running, RhinoGold does not work either.
The problem is since I switched to Rhino 6 and I have already tried everything to solve the problem myself.
There are different error messages, but all of them have anything to do with the License.

Could please somebody help me ?
Thanks B.


#2

How is your license installed, locally on one machine or did you create a Rhino account and put your license in the cloud Zoo?

Can you post some screenshots of the error messages?
(please do not post anything that shows the license key itself here)


#3

Rhino is running on my PC and on my Laptop.
Last year I reseived a message every time,I have to log into my Rhino account, when I tried to start Rhino.Only after many attempts the program started.

I’ve noticed now, that Zoo has been installed on both devices .
I was very suprised about that, because it says on the Rhino website, you should not use zoo if you’re a single user (with 2 devices).

Starting the program offline on my laptop:
Rhino starts,shows the toolbar, than I get the error:’’…Rhino is not working correctly…because of a Problem the program is not rightly executed…close the program , inform us about the problem by email.’’

Starting the program online on my laptop:
‘‘You won’t keep the Lizenz on this computer ?’’
Yes. Zoo is starting.
Rhino starts,shows the toolbar, than I get the error:’’…Rhino is not working correctly…because of a Problem the program is not rightly executed…close the program , inform us about the problem by email.’’

I tested different ways , but nothing helped.


#4

The local (LAN) Zoo? You sholdn’t need that at all.

That info probably relates to Rhino V5, not Rhino V6. For Rhino V6, if you want to use a single license on multiple devices, you MUST either install it on a LAN Zoo (designed primarily for use on a company or school network), or if you are just a single user the Cloud Zoo.

I suspect your license is indeed in the Cloud Zoo, if it asks you to login to your account. If you use the cloud zoo, Rhino will not run if you are not logged into your Rhino account. However, you should not need to do this every time you run Rhino, just occasionally, like once a month or so when it asks.

This part is correct up to that point. If you have your license in the Cloud Zoo, when you start Rhino on one of your machines, it will try to find your license. If you are offline and you haven’t used Rhino on that machine in a couple of weeks, Rhino will not start because it can’t connect to see if you have a license.

If you are online, it will check the cloud Zoo for your license. If it finds one but it has been last used by your other machine, it will ask you the question if you want to switch the license to the machine you’re on. Normally if you answer yes, it should work.

This is the problem. I don’t know if it is a license problem, or if it is some other technical problem. If you see any error messages on the screen, please do some screenshots and post them here, it might help. Can you start Rhino in safe mode at all?


#5

Hallo Helvetosaur,
thanks for helping me.
I don’t remember that I have ever installed zoo by myselve. I also had no choice to decide between Cloud or Lan .
I’ve uninstalled and installed the program several times to get it up to get it running .
I am using Rhino every week, now it’s running on my PCverry well.

But for the Laptop I don’t find a solution.
I have tried to choise different answers, yes/no.
Rhino also finds the license, but the program stops .
I’m getting impatient now because of spending so mutch time for this problem, because I need Rhino for my work , when I am on the way.

Do you have any idear, what I could do now ?
The program has always worked on both devices before upgrade.

So, here you are the screenshots.
1.Starting the Laptop online .Find the License
2.Rhino shows the toolbar
3.Error
4.send email

Could there be a problem with Gate, the start program of RhinoGold ?


#6

Yes, that could be it. You can try starting Rhino in Safe Mode and then going into Options>Plug-ins, at the top, from the menu choose “Plug-ins that do not ship with Rhino”. You should find RhinoGold in the list - I don’t have any in my list below, but you should have at least RhinoGold -

image

Next to RhinoGold there should be a checkbox “Enabled”

image

UNCHECK that box.

image

If there are any other plug-ins that do not ship with Rhino in that window, uncheck those too…

Then close Rhino, and start it again normally (not in safe mode). Does Rhino run then? If so, then RhinoGold is the problem. If not, it may also be your video card that is causing the problem, but try the above first and report back here.


#7

Sorry, I don’t know, how to start in the Safe Mode.Does this mean to start it with.exe ?


#8

Windows Start, go to “All Apps”, scroll down to the Rhino 6 folder, open it and you should find “Rhino 6 in Safe Mode” (don’t know why mine is in French, I have an English system).

Or just start typing “Rhino…” in the Search bar and Rhino 6 in Safe mode should come up


#9

Rhino starts in the Safe Mode, RhinoGold too and I could work with it.
But it doesn’t starts in normal Mode wether I click on the Options plugin or not.

What does it mean , that Rhino runs in the safe Mode but not in the normal Mode ?

Should I log out first from my PC ( I don’t dare, because Rhino runs finally )in order to login on my laptop.


(Pascal Golay) #10

Hi Barbara - that means that either a plug-in that is being blocked in safe mode is causing problems in normal mode, or, and I suspect this is the case here, there’s a problem with OpenGL, which is blocked in Safe Mode. Can you please run the command ‘SystemInfo’ in Rhino and paste the results here?

-Pascal


#11

Hi Pascal,this could be, the Laptop is a little old, but he always works reliably .
I have had no Problems With Rhino 5 at all and I regret to made the upgrade.

system


#12

This looks really small…
image

Hard to run much these days with that little RAM. 8 Gb is recommended for V6 (also for V5).
image
I’m wondering if you’re not running into out-of-memory problems.

This also looks bad - it should report something.
image

Can you post the whole text (as text, there is a CopyAll button in the SystemInfo dialog).


#13

Pity, I will probably not be able to use the small laptop.
rhino%20system


#14

With Rhino 6 unlikely… I am surprised Rhino 5 ran on it OK…