Linked Block Layers mode without dialog?



Hi All,

I am looking into automating linked block insertions either via macros or RhinoScript.
In the hypenated version of -Insert command I can’t find a setting to set the Layer style for linked blocks (Reference vs Active). I also looked at the hypenated -BlockManager > Properties, but there is also no setting to change that. Is there currently any way to control that without manually using dialog boxes ?

Also, is there a way to change multiple linked blocks layer style from Reference to Active? Now I need to go deeper into block manager and edit each one one-by-one, manually.

EDIT: currently it seems like the layer settings (Active vs Reference) uses last used manual setting.



(Pascal Golay) #2

Hi Jarek - yep, it looks to me like that is indeed missing…



Hi Pascal,

I was digging more being a bit desperate to make it work, and found the registry key where that info seems to be stored:
HKEY_CURRENT_USER\SOFTWARE\McNeel\Rhinoceros\5.0x64\Scheme: Default\Insert defaults\LayerStyle
-but unfortunately changing this via script has no effect. I guess its one of these settings that are read/write only on start/close of Rhino… If there was any other way you could think of to do it it would be very helpful. Otherwise, I guess we need to add this to the pile…



(Pascal Golay) #4

Hi Jarek - I poked around, and I only see a way to get that setting and not set it, in Rhino Common, not that my poking is definitive, I’ll ask Dale F when he gets in.



Hi Pascal, thanks!



I am also interested in finding a scripting method to change layers style of linked blocks.