Linework disappears - old graphics card

Hi,

I have a recurring problem with linework disappearing/becoming invisible. I can still select the linework so it’s still ‘there’, it’s just not visible in my viewport.

This especially seems to happen if I’m doing more complex operations with linework - curveboolean e.g. - or copying and pasting linework between rhino files

I suspect this might be a graphics card issue as I’m running Rhino on an older machine.

The only way I’ve found to make the linework visible again is to close and reopen the file.

Here is my text output from Help > System Information:

Rhino 7 SR14 2022-1-10 (Rhino 7, 7.14.22010.17001, Git hash:master @ d8a2d020be8cb487bfc091316ef32170cfc7eddb)
License type: Educational, build 2022-01-10
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: AMD Radeon HD 7500 Series (AMD) Memory: 1GB, Driver date: 11-4-2015 (M-D-Y). OpenGL Ver: 4.5.13399 Compatibility Profile Context 15.201.1151.1008
> Accelerated graphics device with 5 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.5 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.5
Shading Language: 4.40
Driver Date: 11-4-2015
Driver Version: 15.201.1151.1008
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Import_PDF.rhp “PDFReader”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Any help much appreciated

can you share a file where that would be happening?

This card is far below the needed specs for Rhino 7 and it’s a very, very old driver

Hi Hugh -

As Gijs mentioned, the drivers are very old. You can open the Rhino Notifications panel and follow the links to see if there are more recent drivers for that GPU.

Apart from that, you might want to try to play with the “graphics level” slider that you can find on the Rhino Options > View > OpenGL page. It’s currently set to (Max OpenGL Available) . Slide it over to the left one notch and restart Rhino. If that doesn’t help, slide it over to the left another notch and repeat. Hopefully, one of those other levels works better for your GPU.
-wim

1 Like

Thanks for the advice. I’ve updated my graphics card driver - admittedly only to 7-15-2015 - and tuned down the “graphics level” slider a notch.

I’ll have to upgrade the graphics card at some point but I’ll squeeze as much life out of this old machine as I can before then. It may be an old card but it seems to do most of what I need it to do.

1 Like