Linetype scaling in model space

Done! That’s exactly what I wanted. Just did not know where it was. Yes, it might be more logical under the same page as the others though.

Thanks,
Matt

Got that- added as
http://mcneel.myjetbrains.com/youtrack/issue/RH-27596

thanks,

-Pascal

Whoops, I spoke too soon. That’s NOT exactly it. That linetype scalar in the Options/ Annotation/ Linetypes dialog box works for model space, but it then changes the scale of similar dashed lines in Layout. If you have the linetype scale set to 1, with PrintDisplay/ LayoutLinetypes=ON, then all the dashed lines look the same in Layout. That’s OK for Layouts, but doesn’t work when you go back to model space. In model space, you want the linetype scalar larger, like 50 or 100 if you’re working in large units like feet, not 1. So what I really am asking for is a true model space linetype scalar, like annotations have. The text, dimensions, and leaders are scaled up as a reference in model space, but then true scaled in Layouts. That’s what linetypes should have.

Clear?

Thank you,
Matt

Huh seem work for me here. So if I have a file were the plan is 1/8"=1’-0" (scale factor 1/96) and I set the linetype scale to 96. They look the same in model space as in Detail in layout space. Check out this example of some details drawn at 1-1/2" = 1’-0" (scale factor 1/8). They look both the same in model space or layout space.

TestFile

With that said if you actually draw a line in layout space it would look correct, or if you have two or more Details (viewports) at different scale they won’t look correct either. Although if you use “Match Pattern Definition” in the print options they will print correctly.

Hi Guys,

We’re a year older since Matt started this topic and still linetypes are a real headbreaker.
There’s no way to keep them consistent.

1/ There should be a clearer way of defining linetypes. I’d like to regard them as some kind of helpers, when reading a drawing. So everywhere you encounter a linetype, it should be of a consistent size. Off course, we don’t have the luxury to always keep their visual size the same on our screens, when we’re zooming into some geometry in model-space. But what we cán control is the rendering in paper space. That’s why I prefer to think of linetypes as defined in relation to the (printed) paper. And refer to this scale as scale=1.

e.g. Centerline: 10, 3, 2, 3 (my units are mm’s)
Now, drawing a centerline in modelspace, it should only ‘show itself’ as 50 times larger. Like Matt’s earlier suggestion: Model Space Scaling= 50. Setting the scale for viewing in model space would not change the linetype’s settings, not really.

2/ When coming to the layout, regardless of its scale (1/20, 1/50, 1/100), a linetype should always look the same on paper. And I’d like to have them on screen too, not only after printing.

There are some things making it confusing:
*As it is now, in layout, if we draw a centerline on the paper, Rhino draws this line with a linetype scaled up to the set model-scale. This is counter intuïtive.

  • Also on a layout page, model-drawn lines show up differently than do the paper-drawn lines.
  • We can’t presume all ‘detail views’ to be at the same scale. It would be nice if a drawing at scale 1/100 and its detailed drawings at scale 1/10 would have linetypes at a consistent scale.

Best regards,
Bart

3 Likes

Hi @BartGo (and @pascal)

This is the best description of my battles with Linetype scaling. It’s exactly right, so thank you for being so clear and thorough about it.

I will also update this and say we are now 2 years since BartoGo wrote this (3 yrs since the original post) and - please do tell me if I’m wrong - this still seems to be an issue. I’m using Beta v6 and I had a hell of a time trying to work out the line scales. Same problem - I use multiple viewport scales in a document, and linetype modeling scale seems to have to be set to around 48 or 50 in order to have the lines read properly while drawing (I draw/model in 2D/3D most of the time in room-size contexts)

Has there been any headway on this front that maybr I just don’t understand in v6?

Thanks as always

1 Like

Use Options command to define your custom linetypes.

Hello everybody,

I am new to Rhino and need to ask a slightly different question on the same topic.
First of all I am using the Mac version.
Let’s say that in model space I draw a large rectangle, line weight 3mm.
In layout I need to have a detail of that complete rectangle on a small scale (1:25 or 1/4") and an other detail showing a corner of the same rectangle scale 1:1.
For the full size detail I need the line weight to be 3mm which works out fine but by having that the detail with the rectangle on a small scale can’t be read.

is there a way to basically fix the line weight to the model space so that will come out to scale in different details?

Hi Irene,

is there a way to basically fix the line weight to the model space so that will come out to scale in different details?

I believe it is this option in the Print dialog that you are looking for.
I made a simple model and it is attached.

image

You can preview this on the layput with the PrintDisplay command configured like this:
Print Display (Layout Viewports) ( State=On Color=Print LayoutLinetypes=On ):

Let us know if this works for you.
Sincerely,

Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA

lrene linetypes v5.pdf (6.9 KB)
lrene linetypes v5.3dm (34.3 KB)

Hi Mary,
Thank you for the reply.
Unfortunately it’s not fixing the issue.
Maybe I phrased it in the wrong way. I’ve attached a print from a basic model, that should explain a bit better.
The line next to the man has thickness 1mm in the model.
The view on the right is 1:1 and it’s fine at 1mm thickness, I do want a nice thick line.
The view on the left is 1:25 and due to the line thickness, it’s not easy to read, it’s merging into itself. If it was to scale, a line 1mm thick full size should ideally be very thin when view at 1:25.
Does it make any sense?

1.pdf (745.9 KB)

So far I had solved the problem by keeping a thin line in the model space (0.18) and then, when doing full sizes, I would in the viewport trace over with a 1mm thick line. It allows me to get to the print I need, it’s just not very practical because if something changes I have to retrace over every time.

any idea? :slight_smile:

If you want to scale line width globaly per plot, you can do it in the print dialog:

The following is based on the Windows version, but I assume the Mac side has something similar. You can also adjust line weight per detail via layers. So in your 1:25 detail, double click into the detail to make it active. You can then modify all the object on a layer you are interested by using the per detail controls in the layer pallet. You can leave the line weight heavier in your 1:1 detail.

You can also adjust the print width by the object properties, but this will affect it in all details.

Sam

I don’t seem to be able to navigate linewidth management. I want Linetypes that print at the same size of dash and dot in all windows regardless of the window scale.

Choosing “Use Pattern Definition” in Print Settings doesn’t work as expected. if I rely on scaling dimensions in Options, Using Pattern Definition doesn’t respond to a large enough range of scaling to get them to a large enough scale, and if I edit the linetypes themselves to make them bigger, that setting results in different instances of the same linetype printed to different scales.

Of course choosing Match Viewport Display results in linetypes that are scaled with all the objects, varying from window to window.

I am either mismanaging this or something’s off in my project or settings somewhere.

Hi Djhg,
Can you tell us what Rhino version are you using?
The linetype scale, unit and pattern definitions are set per file in Document Settings. The linetype print style (Match Pattern Definition or March Viewport Display) is set at print time. Rhino does not have a linetype scale per object.

Please send us a sample file and images that will show us what you are seeing on the display. Indication what you feel is incorrect and what you expected to see. Also print to PDF and send that file along as well.

Thanks in advance.
We will be able to investigate the issue more thoroughly.

Sincerely,
Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA

Thanks Mary, but that post was 26 days ago. I’ve somehow limped past it and have other issues to work through at the moment. This is the least of them, but maybe I can get back to it again before too long.

1 Like

Hi @djhg,
When you are ready to revisit this, just post your files and @mention me.
You can also email tech@mcneel.com with any urgent issues.
Sincerely,
Mary Ann Fugier

Also note that Rhino’s display of linetype scale is by and large completely unusable and unrepresentative or what you will get, especially when working with layouts. If you have your print settings set to Use pattern definition, when printed they should measure as they are in the pattern definition. The display will almost always be wrong, so don’t look for the print to match the display. Really the only way to get a feel of what linetype scale will look like is with check plots.

Sam

2 Likes

Thanks Mary.

I put up an issue on the forum last night about Ambient occlusion not working in a particular viewport in a project. It’d be great to get some advice about that.

regards

David

Hi, I have a slightly different question. Is it somehow possible to assign different linetype scales to different lines/objects?
If not, could it be added to a wish list. I think that easiest way would be to add another object property value “linetype scale” for each line separately. Then it would be possible to change this value in object properties tab - either “By Global Value” or different/custom value.
Thank you,
Vaclav

4 Likes

Almost 8 years past and I don’t know if this issue has been solved. I am a user with both Rhino 6 and Rhino 7.
To make is simple, I will use an example to show what I need in my work and what results that these 2 version of Rhino had gave me.
Here is the example. In my work, there is already an existing dash line in a drawing I created in the model space, and I want to add a new dash line in the layout space which can act as an instruction for my drawing. In this situation, what I really want is that these two dash lines must look exactly the same when I turn on the print display button.
As a result, Rhino 6 works well, although the two dash lines are a little different in their scale. I think for me, I can accept this. It seems that the Rhino team have worked on this issue and fixed it already. However, in Rhino 7, it doesn’t wok well at all! In Rhino 7, the 2 dash lines look totally different! And if I change the line type scale in the options, it will change both line types in the model space and layout space. And it turns out that, when I turn to the layout space to watch the two dash lines, only one dash line can fit the paper after my tuning. Either the dash line in model space looks good in my layout with the gaps of the dash line in the layout space look huge, or the dash line in the layout space looks good but the dash line in the model space look like a continuous line in my layout.
As a result, in Rhino 6, this problem no longer exist. But in Rhino 7, this problem reappears like in Rhino 5 8 years ago.
And I don’t know why.

Hi -

FWIW -You haven’t attached anything.
Linetype scaling is working as expected in Rhino 8.
-wim