LINES not showing up properly

I’m not sure when this problem started to occur. I have restore default-ed everything in my display properties, but the problem still persists, so I am not sure what went wrong where. If anyone has any insights or diagnostics they could share I would really appreciate it!

As of now, I can only see proper continuous lines in the “artistic” view, in every other view the lines are broken and weirdly dashes (as in the picture). When selected, they are obviously connected lines, but still weirdly dashed. So I do believe I have messed up a display setting somewhere. Just don’t know where :stuck_out_tongue:

Thank you!!

Without the file, it’s impossible to guess.
They do look like linetype patterns, so did you change the linetype scale in Rhino Options?

Please attach the 3dm file if it’s not too big.

John: Thank you for your reply! This does not happen just to this file, but to every rhino file I open.

Even if you were to send me one, I’m sure it would open with these broken lines.

That particular File is big, so i can send you one that I have with the same problem. But perhaps if you open it, it won’t look the same.

2.3dm (9.1 MB)

Please post a screenshot of your OpenGL information: In Rhino, go to Rhino Options > View > OpenGL.
Also, which Service Release of Rhino 5 are you running?

Your model displays fine here.
The only thing I can find is your model tolerance and grid settings don’t make any sense.
Why are they set as they are?

I can’t tell what you are modeling so I’m at a loss to suggest an appropriate unit and tolerance setup.
Maybe this FAQ will help:

@wim is right.
We need a screenshot of the settings in Options > View > OpenGL

I also see this problem. I am an speaker/instructor at a coding professional conference and we recently purchased 18 laptops to use for our maker lab. They are all the same make HP pavilion i5 8th gen with intel UHD 620 cards… open GL version is 4.4.0

This happens with all files on these boxes, along with an odd issue where grid lines irregularly draw.

V5 doesn’t like the Intel HD chips at all.
That’s why the OpenGL details in the System requirements says to avoid them.

My guess is if you uncheck the copy option on the OpenGL page for using Accelerated hardware modes, you may get better results.

V6 will be some better.

OK, that will be a lot easier for the kids to use i think… there are now clear lines and the grids render…

What sort of issues will we see leaving it set this way?


Nothing that will affect modeling or performance as the Intel chips aren’t accelerated anyway. There will be some differences in how some of the fancier display modes work. The Microsoft GDI Generic driver does not support high enough OpenGL version for some of the features.

Thanks for the advice… Any display modes i should avoid? I use ghosted a lot with the kids…

Rendered, technical, artistic, and pen may be problematic when you turn off hardware acceleration. Performance will also be affected when dealing with scenes that have a lot of geometry.

Pen and Artistic won’t work the same.
Shadows won’t work in Rendered either.

Just minor “eye-candy” stuff.

Thanks everyone! and especially John!

We ran this year’s classes with this problem, and it drove the kids nuts! Despite this, every kid in the class was able to create a nice basic rotated cup and most got to print them! One kid (age 8) stayed over after class and was able to add a r2d2 style lid with a straw hole to her cup! Seeing kids successfully work on a nice package like Rhino as opposed to a “dumbed down” kids app was a real joy!

I can’t wait to see what these kids do with this hurdle fixed!


Thank you, John, Becarnes and wim for helping me out!!

My original settings were:

When I open my “About Rhino” it says:
Version 5 SR12 64-bit
(5.12.50810.13095, 2015-08-10)
SN: 4-1500-0103-100-0041774-18007

Regarding my questionable tolerance setup, my instructor told us to adjust the tolerence to a small number (vague) to avoid problematic linework when using “project” and “Make2D” so I just punched in a lot of 0’s. So, there’s not really a reason I used that specific small number. I also tried scaling the tolerance up, but it was still the same problem.

However, after I uncheked the accelerated hardware mode, the artistic mode went black at small scales, but my lines were fixed in wireframe and other views! Yay! I will keep this strategy in mind, even though I don’t understand what accelerated hardware means. :stuck_out_tongue:

I was pretty sure it was an acceleration issue, because most of the time if i tried to screen shot it, it would look fine on the screen shot LOL :smiley: that’s why i used my life cam to grab the pics. Acceleration refers to using the graphics card to render graphics faster/smoother. when i figured out it was the display i just apologized to the kids and told them the points were there even if they could not see them all. Strangely, this seemed to bother the moms and dads more then the kids #kidsthesedays