Lines and surfaces not showing in any view or if unselected


I am a student (unfortunately, don’t have much experience with Rhino yet). I work on Macbook pro 2019, downloaded the MacOs big sur. yesterday. Up until now, Rhino worked normally, but when I opened it today and tried modelling a simple chair, no lines or surfaces were visible until selected. And even if selected, the line is only dotted. If i unselect it, all lines suddenly become completely invisible. I tried the hide/show command but it didn’t work. I also checked if there could be something wrong with viewing polylines but everything seems okay. Again, I don’t have much experience with this system so I don’t really know if something is wrongly set. I tried searching for solutions on Google but nothing came up. There is almost no possibility that my computer simply cannot process it, it worked fine all along and since it’s almost brand new, there should be no problem with my graphic card or processor. Please, I will appreciate any comment or tip on how to fix this, I cannot afford to dwell on this issue too much since I have deadlines where Rhino models are absolutely necessary. Please, help me. Thank you.

Did you by any chance switch to Rendered mode? In Rendered mode curves and lines do not show up by default. It’s also possible that you may have accidentally modified one of your other display modes to not show curves.

Otherwise please run SystemInfo in Rhino and copy/paste the results here.