Lighting a partially transparent surface

I’m finding that if a surface contains a material assignment which applies transparency in even a miniscule amount anywhere on the surface (or if a surface is set to be transparent by any mount other than zero), no part of that surface will be illuminated by light striking it in a raytraced view. Is there a way around this?

I think an example would help…

Yes please, attach a minimal example srt up as you need it.

A 50% transparent surface should be illuminated by 50% of the light which hits it. I’m trying to find out if Rhino should faithfully reproduce that, because it isn’t in my project. If it should I’ll trouble shoot it, and if it can’t I can move on. (I hope this is simple enough. Working on proprietary projects with tight deadlines…) A this pint my work around is to make the material in question self illuminated, but it’s not the best soloution.

50% transparent what? Can’t you make up a trivial example with primitive shapes?

an open surface. just a rectangular surface with a material assigned.

What’s the material supposed to be? Seriously give us a sample file. For all I know it’s just the gamma settings, if they’re not right then no adjustments are going to look linear to your eye.

I appreciate the interest. No gamma settings - these are photographs of people. Light rays go completely through this surface without illuminating it and illuminate surfaces behind it, but the surface remains dark. Though most of the surface isn’t transparent at all (only some of it is.) Hoping to find out if this is just the way Rhino works.

Hello -
Does this mean there is an alpha channel in the material’s texture, or? Any simple example is better than trying to guess what you are asking about.


I did a very simple example and it seems to work as you want here. So maybe the culprit is your alpha channel not doing what you think it’s doing, but again can’t say with no example.

Please add a 3dm file with everything set up as you would like it.

Words are nice, but often times users do things differently than I understand, so a file is hugely helpful.

Thanks for the assistance.
If I make the material transparent by any percentage with the material transparency slider, it receives no light at all in Raytraced mode. It’s a dark opaque shape and the light hits objects behind it.
If I introduce an alpha channel by keying out some of the image in the material using colour masking - same thing.
Rhino’s rendering something but if I can I will make an example. It means creating a new image to use as a material, with key colour and lighting setup.
But again, if Rhino raytracers simply render any transparency as 100% transparency as far as receiving light goes, then knowing that I can proceed understanding this limitation. If it should work. I can at some time troubleshoot this setup.

If I make a simple surface and make it 50% transparent, I get what looks like 50% of the shadow and 50% less illumination. You’ve got all these people trying to help and I’m still not seeing a sample file, I’m done until I see one.

Thanks Jim.
I can send a file, yes, thanks Nathan. There’s a way to save it which automatically packs the linked and material files, I believe? (In autocad, it was “pack”)

When you Save As your file ensure Save Textures is checked in the save dialog. Saving for the first time when you name the file also has the checkbox for saving textures.

As far as I can tell it all works as it should (assuming this is what you meant):

djhg__materials_and_lowered_opacity.3dm (8.9 MB)

Thanks Nathan. The project in question is well over half a gigabyte in size so I’m hesitant to send it. I copied the difficult transparent objects and their lights into a new project and - once I adjusted the lights a little - the surfaces responded to light as I would expect. I brought the subsequently altered lights into my project, and have the same issue as before. I can adjust the lights’ brightness until they flood the surfaces behind the translucent ones, but (in the project scene) the brightness doesn’t change on the translucent objects immediately in their path. There’s something about my scene which is inhibiting this. A persistent shadow cast on the surfaces, maybe. Rather than sending the project I will send images of how the complete scene looks vs the isolated scene. (sent to to your attention)

open surfaces render poorly with transparent materials.

you will want to add some thickness for the best result.

Thanks Kyle