Light Emitting Objects


#1

I can get objects to emit light - to product a glowing effect, but I can’t get this to work with the Render Cache turned on.

I love the speed of the Render Cache - it’s way too slow without it turned on. Are there any settings that can allow me to keep the speed and the glowing effect I’m looking for?


(Brian James) #2

Hi Paul,

You might be using auto-occlusion with a large shadow distance which makes the brightness material less powerful. I’m guessing without seeing the file though. I personally would use brightness in combination with an actual light and process the raytrace with Neon. I do this here…


#3

I have been adjusting the shadow distance - and still cannot get objects to generate a good glowing light. So Neon does a better job than brazil in this area?


(Brian James) #4

There are many factors involved here… Can you post a model?

Neon raytraces in the viewport but doesn’t use a render cache. It will use other Brazil settings though like GI and can use the brightness material.


#5

Test.3dm (376.1 KB) Sure. I’m attaching an example of what I am working through.

This is what I typically use - the render cache turned on - which makes rendering time doable. 16 seconds.

This one - the light is visible in bouncing back from the panel. 1 minutes to render.

Neon - I let this roll for 2 minutes. Grainy, but accurate.

I know the easy answer on this is go with the versions that don’t use the Render cache, but alot of times when the model becomes very large and I am on a tight timeline - render cache is the only way to go. Rather than 2-3 hours a rendering- it’s 15 minutes. But I always have to forfeit on indirect illumination. Making me Photoshop of lot of lighting in the end.

Any suggestions?


(Brian James) #6

Hi Paul,

How’s this work for you… 5:30 on an i7 950 at your resolution of 1650x1055. If you have any questions about what I did just let me know but I bet you can poke around and figure it out.

light_test.3dm (303.4 KB)


#7

Thanks Brian, that looks great. Can I ask what settings you used to achieve this?


(Brian James) #8

Hi Paul,

I adjusted many things including the materials and irradiance map settings. I didn’t see a simple way to make your file work so it was necessary to start over. Take a look at the Brazil settings in the file I posted… with that said, here’s a run down from memory that might also help.

  • decrease the undersampling min/max values in the render cache.
  • reduce the auto occlusion distance
  • make the middle material a Brazil glass material with glossy refraction and a custom refraction color
  • increase the GI sample rate in the luma server

You can save the settings out for use in another file and also save the materials via the right click menu over the material swatch.


#9

Thanks Brian. I learned a lot based off of the settings you sent over. I like the speed and rendering smoothness that the auto occlusion at the low settings provide - but to get accurate indirect illumination lighting it needs to go to a higher value - taking the speed and (becoming blotchy in quality). The quality can be fixed by increasing the QMC sampler (which takes more time)

Thanks! I’m not sure if I would have figured that out without that settings comparison.