License not found! every time

Ive downloaded the Rhino 7 trial, uppdated my licenses on “my page”, but get this message. Tried installing twice now. Cant get past this error message, as Rhino crashes every time after it comes up. What to do?

I see a V7 eval license was recently added to your login account.
Are you sorted?

Hi John,
Thank you for geting back to me. Im still not able to start Rhino 7 on my iMac, (I run OsBig Sur). I get this message every time.


have updated my account settings online, but still no luck.

Kind Regards
Bjørnar Kvalen

The screenshot of the license page shows 1 - license in use. If after Rhino exits - with nothing running, is it still at 1 or does it go back to 0?

If you click on the ‘1’ it should tell you what computer it ‘thinks’ is using the license

Hi, It seems to have no record of a device. Nothing in historical usage either. Hmm

@John_Brock - can you check this person’s account and see if something is ‘stuck’ there?

Hi. I still have not heard anything back from suport regarding this. I have tried re-installing Rhino 7 several times. Also updating my account. However Rhino will not start on my Mac, and keeps telling me It can not find a license. Can you give me some help please. Thank you.

Hi @curbno -

Did you get your license issue sorted out? If not, please email

Hopefully you got your issue sorted out and you are up-and-running.