License Manager initialization failed with error -200

I do have the V7 WIP installed, do I need to remove the non-WIP Rhino 6? is it causing confusion between the different versions?

You shouldn’t have to remove V6. Maybe @kike can help figure out what is happening.

Please start Rhino WIP using the desktop icon and enable debug logging like this:

-_TestEnableDebugLogging _Enable=Yes _SaveTo=File

Then close and restart Rhino from Revit. When it crashes a file named RhinoDebugMessages.txt will be created in your Documents folder. Please send that to me - it should help me see what is going wrong.

Thanks for your reply; I’ve attached the file here - hope it has something helpful

RhinoDebugMessages.txt (7.8 KB)

I need some more help.

Please unzip and open the file “Enable RhinoSDK Messages.reg
Then run again Rhino inside Revit.
Some message boxes should appear.
Please capture those messages using some screenshot tool like Windows Snipping Tool and send it back to me.
Remember to open the “Disable RhinoSDK Messages.reg” to turn those dialogs off again.

The first message stayed the same but the second one is better, I’ve attached both here



Hope this is more useful, let me know what I can do next to help

It seams you are using Windows 10, but could you please confirm me the exact version and also tell me if it is a server edition or not?

Apologies for the late reply, been away from the work PC;

I am running windows 10, its an “Enterprise” version; Version 10.0.16299 Build 16299
and no, its not a Server edition.

Did you try “Repairing” V6 in Control Panel?

Just tried it - didn’t work, unfortunately, still same error (at least I think its the same); the error -200 and then the following:


Could you please try to generate a dump file of the Revit process when you have this message box on screen?

  1. Press Ctrl+Mays+ESC Task manager will open…
  2. Go to the details tab.
  3. Right click on Revit.exe
  4. Select “Create dump file”
  5. A file called “Revit.dmp” will be create in your temporary folder. Use to be "C:\Users\%USERNAME%\AppData\Local\Temp".
  6. Please ZIP this file and send it to me using this link to as e-mail recipient.

I’ve just submitted the dump, it was taken as soon as the -200 message popped up. Hope it sheds some light on what weird things I have in here that cause the problem.


Analyzing the dmp file seams that you generated it when Rhino was stopped on the first dialog.
Could you do it while the second dialog is on screen?

I’ve re-uploaded the 2nd file again - i think the first one might not have gone through. Please let me know if you find out anything. Thanks

I’m sorry, maybe I was confusing in my previous message, but in order to make this useful I need you generate the .dmp when this dialog is on screen.


Please follow instructions on the previous post about before generate the .dmp.

Sorry bout that - I thought thats what I did - maybe i sent the wrong one. I’m just uploading the dump with the second message on the screen (looks a little different so I’m not sure if I missed a step somewhere - if it’s still wrong i’ll try again tomorrow)

hope its what you are looking for this time

Your last capture shows the same message as in the first post

In the 9th post you showed me this other capture.


The content is different

“Could not load file or assembly ‘Microsoft.WindowAPICodePack.Shell’, Version=,…”

If you can reproduce this again, please capture the dmp.

I found a tool that could help testing if there is an incompatibility between two Revit plugins, it’s free and open source.

It allows you to disable all but one plugin easily and test if it works.
If it works alone then you can enable more plugins and test again until found if two plugins are not compatible.

To download and install please follow instructions found here:

  1. Download the tool from Bitbucket here.
  2. Find where you downloaded the zip file and unzip it.
  3. When unzipped, there will be a BIN folder; browse into the BIN folder then the Debug sub-folder.
  4. Run the tool by double-clicking on the exe file.
  5. In the window that opens, pick your version of Revit (or go with all if you like).
  6. The data grid will update to display all of the machine wide and the logged in user specific add-ins installed. You can pick and choose, invert, select all, then simply click on the “Enable/Disable” button to either enable or disable the selected add-ins.
  7. Once you’ve made your choices, start Revit in the normal manner. Simple and easy.

Or download it from here.

Got it to work… Thank you.

It was a conflict with a content management add-in called Avail (version, we’ve had a problem with this Add-in conflicting with Dynamo in the past.

I’ve manually disabled my user-land plugins but didn’t expect a conflict with system ones. Once IT gave the access needed to work with those it was simple. I’ll submit a dump with just the RiR and avail plug in through the link you’ve provided me previously - hopefully it helps in figuring out what that are doing that RiR doesn’t like.

Thank you for your help through this process.