Licence checkout not working


#1

Hello,

I have a problem with one client checking out a licence for offsite usage. We have a Zoo 6 server running without problems. Other clients can use or checkout licencences as described but one client can not. He does not even see the licence in the Rhino options window. Nevertheless using the licence is possible as I can see in the Zoo admin window. I deleted and re-installed Rhino and all other McNeel applications on the client but the behavior remains.

Any ideas what to check or to modify?

  • Axel

(Dale Fugier) #2

Hi @axel.pruin,

What version and service release of Rhino is the user running?

If using Rhino for Windows, make sure he is running the SR14 service release.

https://www.rhino3d.com/download/rhino/5.0/sr

– Dale


#3

Hello Dale,
the version used is the latest. Actual it is

5 SR14 64-bit (5.14.522.8390, 22.05.2017)

The user grabs the licence as i can see in zoo. When installed the second time I had to enter the zoo server address so i am sure the system is running on the zoo licence. If i disconnect the machine from network I can not start rhino.

Axel


(Dale Fugier) #4

Hi @axel.pruin,

Does the user actually check out a license (Tools > Options > Licenses > Checkout)?

He does not even see the licence in the Rhino options window.

Perhaps we need a screen capture?

– Dale


#5

Hello Dale
As requeseted:

Licencecheckout from comand line has the same result.

And at the same time the Zoo screenshot (irrelevat information removed)

Axel


(Dale Fugier) #6

Hi @axel,

Can you make sure the LicenseOptions plug-ins is both installed and loaded?

If you don’t see it in the list of installed plug-ins, you can install it manually Rhino’s plug-in’s folder.

– Dale


#7

Hello Dale,
the plugin is reporting active and loaded:

The licence is still not visible in the window.

Axel


(Dale Fugier) #8

Hi @axel.pruin,

Most unusual.

Since this is not something we hear of, I don’t have a canned answer to give you (on how to fix this). So I’ll have you try a few things and see how far we get.

1.) Run Windows Update. Make sure the system is up-to-date with all Microsoft Windows updates, hot fixes, etc. The panel use uses the .NET Framework 4.0. So you will want to make sure all .NET updates and fixes are applied.

2.) Repair Rhino. To make sure all of Rhino’s components are installed correct, repair your Rhino installation by running Control Panel > Programs and Features > Rhinoceros 5 (and Rhinoceros 5 (64-bit) > Repair.

3.) Check the logs of any installed virus detectors or malware applications to see if they are blocking any Rhino components.

There may be more to come…

– Dale


#9

Hello Dale,
I checked as requested.

  1. Windows is latest version no updates listed when running windows update.

  2. was not possible as the temporary files used during installation dissapeared. I checked with the update tool and the system is reporting that we use the latest version. As I re-installed rhino just a few days ago I expected this behavior.

  3. The virus detector hasn’t reported anything. I also switched it temporarily off with the same result.
    All other machines with Rhino in our system run the same scanner with identical settings and it is really unlikely that just this machine blocks something.

Are there some registry settings modifying the behavior of the licence tool?
I noted that even after completely deleting Rhino the machine had still some information of the last install as it remered my name and e-mail during the setup and installation.

Is there a tool to completely remove all traces of a previous installation?

Axel


(Dale Fugier) #10

Hi @axel.pruin,

This whole thing is highly unusual. You might want to call into our tech staff (206-634-4588). They may need to remote onto the problem system.

– Dale


#11

Hello Dale
calling your tech staff is a bit problematic as we have a time difference (I am in Europe)

In the meantime I completele removed all Rhino SW again from the machine and made a complete re-installation. - Same results

While playing around I noted the the button “check out” is there but invisible. It seems that the colour of the characters is the same as the colour of the backgound.

As workaround OK for me. If someone has an idea to modify character colour please let me know.

Axel


(Dale Fugier) #12

Hi @axel.pruin,

Run Tools > Options and click the “Restore Defaults” button on both the Appearance and Appearance > Colors pages.

Also, if Windows is using a customize theme, you might want to set it back to a standard one.

– Dale


#13

Hello Dale,

I tried it without any change in behavior. There is also no special theme active. The behavior is also identical for different accounts on that machine, so it seems to be user-profile independent.
The button is not visible, but if you know where to click the action is performed.

Axel


(Dale Fugier) #14

Hi @axel.pruin,

Sorry this has taken so long to resolve. As I’ve said, I have not heard of this behavior. So I’m struggling with suggestions.

What version of Windows is this system running?

What is the video card in the system? A screen capture of Rhino’s OpenGL page would suffice. (Tools > Options > View > OpenGL).

Does this system using a high DPI monitor? Rhino 5 does have issues running on high DPI displays.

https://wiki.mcneel.com/rhino/5/video/highres/toolbars_and_text_too_small_in_64-bit_rhino_5_on_high_resolution_screen

Anything else you can provide might be helpful.

–Dale


#17

Hello Dale,

tha machine was not available last week so I couldn’t respond.
The machien is running Windows 7. All patches are installed.

The graphic system is NVIDA quadro K1200M ap per OpenGL page,

and the problem is independent from resolution. I checked on Laptop screen, standard monitor and on the 3-screen solution without any change.

All other programs on the machine are operating also without any trouble. Unless there is a specific coulour mode just for this window I have no idea how to solve the problem.

Axel


(Rodrigo Bárcena) #19

@axel.pruin
I might be able to do a teamviewer session with you from our Europea noffice.
I’m usally availabe 9-15h CET (not this friday, it’s a public holiday here)
Send me an e-mai lto tech.eu-at-mcneel.com to schedule it.

Thanks!