Layouts print as blank pages

This is a reoccurring issue that I’ve been having since Rh6, as far as I can remember. And still currently exists in RH7 sr14. This is not specific to a file, but occurs when there are 30-50+ layouts. Happens on multiple PDF printers.

The issue is, whenever in a file there are a lot of layouts (let’s say between 30-250), and I print them all as a single pdf - they print out blank. This does not happen, when the layouts are freshly generated - then they print out nicely. This happens, when I open up the Rhino file that is already containing the layouts.

What I understood is that happens, is that Rhino does not “refresh” those layouts when opening the file. Thus, when printing them, they print without their content. The only workaround, I’ve found is to manually go open up each layout prior to printing. So, manually “refreshing” them.

This seems to be related to the number of layouts and to the number of detail views. On a small number of layouts, this does not happen, but when you go past some threshold, then it’s with almost 100% certainty that the issue occurs. I have a file with 145 layouts, and ~roughly ~900 detail views I can send privately for testing purposes.

On some occasions, with a relatively low layout amount, I’ve been able to get the file to print if I save the file on Model space, and then reopen. Compared saving the file and starting view in Layout space.

Hi Toni -

Yes, please do so.
Also, please run the Rhino SystemInfo command and copy-paste the result here.
-wim

I’ll send the file through private message.
Here’s the system info of my laptop, I’m currently on. This, however, happens on other computers as well. The plugin setup is somewhat similar on those machines, though.


Rhino 7 SR14 2022-1-10 (Rhino 7, 7.14.22010.17001, Git hash:master @ d8a2d020be8cb487bfc091316ef32170cfc7eddb)
License type: Commercial, build 2022-01-10
License details: Cloud Zoo

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics 630 (Intel) Memory: 1GB, Driver date: 1-8-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1
Primary OpenGL: NVIDIA GeForce GTX 1050 (NVidia) Memory: 4GB, Driver date: 4-8-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 462.31
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-8-2021
Driver Version: 27.21.14.6231
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Geometry Gym\Rhino3d\ggTekla.rhp “ggRhinoTekla” 1.4.22.0
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\LayoutManager (23664189-f095-4e9c-8f6d-1073c2c60efc)\0.2.6.0\LayoutManager.rhp “LayoutManager” 0.2.6.0
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Users\Toni\AppData\Roaming\Grasshopper\Libraries\elefront421\ElefrontProperties.rhp “ElefrontProperties” 1.0.0.0
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\export_ACAD.rhp “AutoCAD file export : export_ACAD”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\BlockEdit.rhp “BlockEdit” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”

Same problem here, pages are blank after a dozen printed correctly. Any solution?

@N11 I have not heard anything.
@wim Any info on this?

As a workaround you need to open (activate) each layout. A lot of Ctrl+Shift clicking.