Layout view isn't saved

Hello there,

I’m having issues with saving my layout views. (v. 7.12.21313.6341.)

If I have adjusted my layout view, and save the file, and then I restart the program, the layout view shows nothing inside it. I’d like to have it in the same place for exporting different layers for photoshop.

Do I need to save a “named view” separately in the layout mode in order to have it really saved? If this is the case, it’s a little bit unintuitive. I’d hope that a layout view would automatically save if the file is saved.

Hi Vesa -

That’s not the way it should be and I can’t make Rhino behave like that on my system.
Please run the Rhino SystemInfo command and copy-paste the result here.
-wim

1 Like

i had similar troubles. try locking the details views

Hi Juan -

If you have something that is reproducible, please let us know.
-wim

Thanks for your answer! Here’s my system info:

Summary

Rhino 7 SR12 2021-11-9 (Rhino 7, 7.12.21313.06341, Git hash:master @ 5590153808223b57a9f41516a969fd949aa81bff)
License type: Educational, build 2021-11-09
License details: Cloud Zoo

Windows 10.0.18363 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 3GB (NVidia) Memory: 3GB, Driver date: 4-12-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 466.11
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-12-2021
Driver Version: 27.21.14.6611
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 3 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Users\Vesanette\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.21124.1031

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

SYSTEM INFO

This text will be hidden

I’m not exactly sure how to reproduce the bug, because it seems that it doesn’t behave logically.

Sometimes the program does save the layout view, but more often I have some kind of bugs concerning the saved layout. In times, it does save the layout view, and in times, it doesn’t. Really weird behavior.

And I’m writing this post because it has happened over the last 6 months many many times after I started using the layouts.

Hi Vesa -

That kind of issue is hard to deal with. If we don’t find a way to reproduce the behavior, we can’t fix it.
Please keep an eye on this and try to find a pattern. I see that you have 2 third party plug-ins loaded - since you say that this behavior is rather frequent, could you disable those plug-ins for a while and see if the behavior still pops up?
-wim

Hmm, after disabling enscape plugin I don’t get the problem anymore, at least for now.

This is how I have done my layouts:

  • new layout
  • name layout view
  • set scale and pan to preferred view
  • lock layout

Hi -

Thanks, there’s nothing out of the ordinary in that workflow so that should just work fine.

I’d leave it disabled for now…
-wim

thanks for your help wim! I’ll keep an update if the problem occurs again.

i am the same person.

these issues might be related

After disabling enscape -plugin I haven’t had the particular problem so far today… might be the cause.