Layout Space - Can add text, but can't draw curves

Hi. I’m trying to add 2d geometry (lines, rectangle border, etc) to a layout page (not the details themselves) but, as soon as I draw it, the geometry disappears. Ie. it looks like i’m creating a rectangle, snapping to points etc, but then when I hit enter the lines disappear.

I can add text and dimensions to my page, so the layout space is receptive to additions, but I can’t draw. Is this a glitch? or am I doing something wrong?

thanks in advance for any help you can provide.

Hello - can you please try turning off ‘GPU Tessellation’ in OPtions > View> OpenGL and see if that makes any difference?
Can you also post the results from the SystemInfo command?

-Pascal

Thanks pascal.

Tried turning off GPU tessellation, but no change. still can’t draw.

here is the result of “system info”

Rhino 6 SR8 2018-8-28 (Rhino 6, 6.8.18240.20051, Git hash:master @ d037927543424e8b3ce54e46b435866178a6349c)
Licence type: Educational, build 2018-08-28
License details: Cloud Zoo. In use by: jlemond ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-HARSQO1

GeForce GT 750M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 382.05)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 5-1-2017
Driver Version: 22.21.13.8205
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”

Did your layout somehow get set to a display mode other than Wireframe?

Hello - thanks -you might try updating the video drivers - they’re a little old, as these things go, from the NVidia website. Also make sure the display mode you’re using in the layout has curve drawing enabled, (Display panel)

-Pascal

I doubt the drivers are at play here. If you can draw curves in the detail viewports or in the regular modelling viewports, then something else is going on.

problem solved. total user error. in display panel curves were unchecked. thanks pascal (and steve)!

Phew!

-Pascal