Layout locked detail view display glitch

Hello here,

A strange behavior is happening when we made layout with locked detail view on it.
Here’s a video to show what’s going wrong (sorry for the poor video quality but all the recorder that i tried doesn’t worked as expected…).

This display bug stay even if i save the file or change of PC until i fix it.
It happens on VA object but if my memory is right, i have seen this before without VA installed.
A fix is to unlock the view and move or zoom on it. Obviously it’s not viable to do this on every layout of every project.

Any clue on how to fix it ?

Hi Flavien -

I’m not really sure what I’m looking at…
At any rate, please run the Rhino SystemInfo command and copy-paste the result here.
-wim

Rhino 7 SR23 2022-10-9 (Rhino 7, 7.23.22282.13001, Git hash:master @ a931168ca9426920ae6aa97218710b662f17fc39)
License type: Commerciale, build 2022-10-09
License details: Cloud Zoo

Windows 11 (10.0.22000 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [99% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 2-18-2022 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3050 Laptop GPU (NVidia) Memory: 4GB, Driver date: 3-17-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.15
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-17-2022
Driver Version: 30.0.15.1215
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Users\f.bessiere\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\eleFront\4.2.2\ElefrontProperties.rhp “ElefrontProperties” 1.0.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.23.22282.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.23.22282.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.23.22282.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.23.22282.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.23.22282.13001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.23.22282.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.23.22282.13001
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\RhinoScriptEditor.rhp “RhinoScript Editor” 7.23.22282.13001

And more details on what i’m tring to show on the video.

1- First there is a detail view of “TOP R+1” on the layout named “Plan d’étage R+1” with doors not showing
2- But in the rhino viewport the view “TOP R+1” is showing these doors
3- If i change the render mode (VA or Rhino style) nothing happens, even in wireframe mode the doors aren’t displayed.
4- The only way I’ve founded to show these doors again is to unlock the details view, move or zoom in the view and then relock the view. (If I change the scale in the view properties panel, it does nothing, i have to do this with the mouse)

Hi Flavien -

Thanks for those details. Would you be able to upload that file on Rhino - Upload to Support with reference to this thread in the “Comments” field on that page?
-wim

Done

I precise that the doors are VA object.

Hi Flavien -

Yes - when I look at the top view in model space without having VA on this machine, there aren’t any door curves there either:
image

I’m moving this to the VA category for the time being.
-wim

Hi @flavien.bessiere,

Please, could you share the file with us as well? You can post it here or send it to visualarq@asuni.com

Hi Alfonso, i have sended the file.
Thanks

Hi @flavien.bessiere,

We have been looking at this issue and the problem is that the view you are using is not completely vertical, so that 2D representation is not activated by VisualARQ. If you set it to Top view you should make it work properly.

How did you define that view?

Thanks, I will look at that.

The view was made using “top view” and “toggle cut plane”

I’m not the drawer here but maybe it’s a wrong manipulation when moving/zooming in the view. But I’d rather think it’s a bug as when i do the trick shown in video, of moving a little bit the view with the RMB, the camera goes back vertical automaticaly. If it was in perspective, let’s say that by mistake the view was moved using ctrl+shift+right mouse button. Then, it turned in perspective, but in that case the RMB doesn’t move the view anymore and tilt it. Do you see what I meen ?

Here’s a better video :

Hi @flavien.bessiere,

I see what you mean. We have made VisualARQ to use the document tolerance by comparing the angle for the view direction, this way you will not have this problem if the view is not completely aligned. This has been implemented in the next VisualARQ release (2.13).

1 Like

Perfect, thank’s again :slight_smile:

1 Like