Layout displays properly but does not print properly

I recently transitioned to V6 MAC from V5 MAC.

I have an 11 x 17 portrait page set up in layout which displays a model in which I have, using setSetObjectDisplayMode, set up different modes both “rendered” and “shaded” to display the way I want in the layout viewport. I have set these different modes from within the layout viewport.

The model displays correctly on the layout page but when I try to print or save the layout to a PDF, it doesn’t show what is on screen. I don’t remember this being a problem in V5, but it seems like it is in V6.

I’ve fiddled around with different print settings to no avail, am I missing something?



Hi Jim - Object display modes will not correctly override the viewport display modes for printing - the print will (should) correctly print shaded views but I would not count on object display modes to mix well or predictably with these… I’d agree the preview should not show what it will not print, I’ll make a bug report for that.

I take that at least partly back… I’m testing on Windows at the moment and it does seem to mix modes in at least the simple cases. Still poking…

@jvm33 - hm. here on Mac, V6, the layout shows me the object display mode but the print preview- the one in the print dialog - does not, so far…


Hi Cal…thanks!

Hi Jim - V7 does a better job of mixing modes. But it looks to me like V6 mac does not do as well as V6 Windows - it only prints the detail display mode, nothing is overridden, as per my first response - turns out that was correct, for Mac, not quite in Windows…


Hi Cal, thanks again!



Hi Cal-

I’m having further issues where I can set a viewport to display “rendered” and it looks good on screen, but a text block that I’ve created on the same layout page only displays the text block when the viewport is set to display “wireframe”. So, I end up with a viewport set in “rendered” mode and the text block I’ve created can only be seen when I switch the viewport back to “wireframe”. Further…when the text block disappears when I have the viewport set to “rendered” and I try to box select the area where the text should be it doesn’t highlight the text block, but it shows up in the text properties dialog correctly. So, I’ve selected something which doesn’t show up on screen, but does display the text in the properties dialog.

I thought it just might be a one off, but it’s happening on new files – here’s an example.

Below is Viewport set to “wireframe” TEST TEST TEST textblock added on top of layout page

Same Layout as above, but viewport set “shaded” – note text block not visible

Same Layout as above, but viewport set “rendered” – text block still not visible

Lastly, if I go to print, what isn’t showing up as a text block on screen, does in the print dialog.

This is all new – don’t remember ever seeing that in V5



Hi Jim - first just verify that your Rendered display mode is set to show annotations. (Rhinoceros menu > Preferences > Display modes)


Hi Cal, Correct. Annotations are/were set to show in both shaded and rendered modes.

Hi Jim - another thing: The layout should always stay in Wireframe - do not change the display mode for the layout itself; change the mode for individual details only… if you see what I mean.


Hi Cal- know exactly what you mean.

So, when both layout and viewport are set to “wireframe” I see the text as below.

If I set the viewport to “shaded” and the layout is at default “wireframe” I don’t see the text as in below.

Note that if I set the viewport to “shaded” and then set the layout to “shaded” the text does show up and that also works for “rendered” and I suspect all the other modes.

hum… I’ll fool around with it here and see what I can find. I am at a loss as to why a detail display mode should affect the display of text that is in the layout space (correct?) @jvm33 Can you post or send me a file?


Hi Cal…just sent you a file.

Thanks again for your help!