Layout Display Issue

unhandled

#1

Just started having this issue after this morning’s update to WIP (6.0.17172.1151, 6/21/2017.) Finding that layout tabs display black - unless zoomed out.

If the layer that the details are on is frozen, dimensions related to their geometry will display. Oddly enough, if all layers are frozen except the detail layer, the issue persists.

When printing, if set to vector mode - layout will preview and print. If set to raster - same black screen.

Have checked all parameters pertaining to display settings, print settings - not sure where to go from here.


(Pascal Golay) #2

Hi John - can you please copy-paste the output from SystemInfo ?

thanks,

-Pascal


(Brian James) #3

Hi John, Does it happen if you disable GPU tessellation in Options>View>OpenGL?


#4

Hi Brian-

Tesselation disabled - doesn’t seem to affect it.


#5

Absolutely! Thanks for the response.

Rhino 6 SR0 2017-6-21 (Rhino WIP, 6.0.17172.1151, Git hash:master @ ac2391d7625174b8a345613c644dbe31837ce3aa)

Windows 8.1 (Physical RAM: 16Gb)

Quadro K620M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 377.11)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 64 MB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” n/a
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp “WebBrowser” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools” n/a
C:\Program Files\Rhino WIP\Plug-ins\AnimationTools.rhp “AnimationTools” n/a
C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” n/a
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots” n/a
C:\Program Files\Rhino WIP\Plug-ins\Alerter.rhp “Alerter” n/a
C:\Program Files\Rhino WIP\Plug-ins\CyclesForRhino.rhp “Cycles for Rhino” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” n/a
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” n/a
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement” n/a


#6

Would be glad to send the file also…


(Pascal Golay) #7

Hi John- thanks - the above catches my eye - I’d go to the NVidia website, get the latest drivers installed, and then let’s take it from there.

-Pascal


#8

Arrgh - of course! First check the cable, then check the Nvidia drivers :slight_smile:

Updated, from 377.11 to 377.48 - unfortunately the issue still persists. Here’s the updated Systeminfo contents:

Rhino 6 SR0 2017-6-21 (Rhino WIP, 6.0.17172.1151, Git hash:master @ ac2391d7625174b8a345613c644dbe31837ce3aa)

Windows 8.1 (Physical RAM: 16Gb)

Quadro K620M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 377.48)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 64 MB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools” n/a
C:\Program Files\Rhino WIP\Plug-ins\AnimationTools.rhp “AnimationTools” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” n/a
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots” n/a
C:\Program Files\Rhino WIP\Plug-ins\CyclesForRhino.rhp “Cycles for Rhino” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” n/a
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” n/a
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement” n/a


(Pascal Golay) #9

OK - I still find it odd that the driver version and date are not available - I wonder why that might be - for what it is worth my driver, from May, has a bigger number: Quadro P4000/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 382.05)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Nearest
Anisotropic Filtering Mode: Medium

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 5-1-2017
Driver Version: 22.21.13.8205

Are you getting the driver by checking the nVidia site yourself, or asking Windows to check? I’ve only once got the right answer from the Windows checker.

-Pascal


#11

Yes, I agree - wondered the same thing when referring to the date / version lines you mentioned the earlier post. No - I do not use Windows Update, I verify the card info with Nvidia control panel then visit their site and download the latest.

Here’s a screencap from that utility: