Layer Panel Shortcuts

rhino5

#1

I want to use the shortcuts in the layers panel to collapse and hide layers. When I select a layer and click the keys “Shift” and “+” it simply types " +" in the command bar and doesn’t actually collapse or expand lists of child layers like the Rhino guide says it will. Does anyone know how these shortcuts work and how to use them without just typing invalid commands in the command bar?


(Brian James) #2

The expanding of a selected layer or additionally the child layers appears to require the use of a Number pad on the keyboard. So Shift + number pad + should work… I’ll file something to update the help doc to explain this. All of the other shortcuts work as expected so I think this is due to the fact you’d need to hold Shift to get to the non-number pad + meaning it’s impossible to press non-number pad + by itself.

If you don’t have a number pad on your keyboard, I think you’ll be limited to the right click menu option over the layer to do this. I don’t see a way to make an Alias for this action. @pascal may have an idea though.

Update: Here’s the bug report for future reference https://mcneel.myjetbrains.com/youtrack/issue/RH-41381
I also forgot to mention that the cursor needs to be over the Layers panel when using these shortcuts so that the Layers panel has the focus.


(Margaret Becker) #3

Information added to the Help for Rhino for Mac and Rhino 6, but Rhino 5 help is no longer being updated.