Latest WIP: "predictive" command text is horribly slow


(Menno Deij - van Rijswijk) #1

When I type one letter, the predictive command text field goes off and takes at least half a second to compose a list of things I might want. If I keep typing, the letters do not show up until the first list is composed.

I don’t want to be a nit picker, but the previous method (with the black command pop-up) was much more responsive - comparable to the predictive command text in the Windows version.

Hint: the searching should be canceled upon key-down when typing the second letter, and resumed with the current content on key-up when typing the second letter.


(Marlin Prowell) #2

I remember this one. This is a bug in OS X 10.9.0 that I worked around, and I forgot to put the workaround in the command options command entry field in the sidebar.

But I forgot to add the workaround because I am no longer seeing the horrible delay I saw in 10.9.0. I’m running 10.9.1 and no longer see a delay when typing. Are you running 10.9.0? Can you upgrade to 10.9.1?

Either way, I’ll get the workaround added to the next WIP release.

FYI, I’m using a standard Apple control that performs auto-completion. The black command pop-up is the same kind of standard auto-completion control that is used in the command options in the sidebar. I give the control a list of “words” (the Rhino commands) to choose from. Starting with 10.9, the control decided to first look up and provide a list of words it thought I would want, and spent half a second to a second finding all the words in its dictionary that matched the first typed letter. Not helpful.


#3

fwiw, i’m not seeing this on my mbp running 10.9.1… the auto complete /suggestions are all happening fast with no noticeable sluggishness

[EDIT] hmm. i am actually seeing a little sluggishness when using a command starting with ‘S’ (of which there are a lot of S commands)… i’ll also see the slowdown if i type S E L L (the first parts of SelLast) then start deleting the letters… it hangs on S E for a bit.


(Marlin Prowell) #4

Yep, saw exactly that, too. I’ve added the workaround, and the auto-completion suggestions now appear instantly.


(Menno Deij - van Rijswijk) #5

I am running 10.9.1

Also, this is the MBP configuration I’m using. It is a couple of years old, but had no problems with auto-complete in the previous versions.


(Menno Deij - van Rijswijk) #6

I think that what some people call a little sluggish is what I mean with horribly slow. Just a matter of perspective :smile: