Latest WIP offline validation doesn't work


#1

Offline install went OK. Obtaining validation code went OK. When I typed the validation code into the box that Rhino puts up during first startup the validation failed. I typed it in with lowercase letters and hyphens, then noticed the box doesn’t format the code like the license key boxes on the websites and Rhino, but I submitted it anyway. It failed. Then I tried it with uppercase letters and hyphens. Then with uppercase and no hyphens. None of them worked. Perhaps if it fails you don’t get another try, but there’s no way for the user to know since there’s no detailed feedback about what to expect nor what’s going on. Then I tried starting Rhino again and typed in the original validation code with uppercase and hyphens. Still didn’t work. On this last try I noticed that the window title line said something about “can’t connect” to something or other while it was thinking about the code I submitted - even though I was offline. I was confused by that.

You know @brian, you say you fully support offline installation, but it sure doesn’t feel like it whenever you change something. It seems more like you just give it merely enough effort to make it look like it should work, but it doesn’t. Perhaps I’ve come to expect too much from McNeel.

Maybe next week. Back to v5.


(Brian Gillespie) #2

Yes, there’s a bug in offline validation that I just fixed, and will have out next Tuesday. I can PM you another build before then of you want.


#3

OK. It will give your fix a field test by an ordinary user, and if I can make it work I’ll be in business sooner.

Oh, and will I have any issues trying to use the original validation that I got today?