Latest rhino 5.4 wip 5E292W issue - CRASH

Ah yes of course @ecnal_van_maanen …you can’t launch to export the preferences. No matter…there’s a workaround:

  1. In Finder, navigate to Go > Go to Folder…
  2. Enter ~/Library/Preferences and hit Go
  3. Find the file titled com.mcneel.rhinoceros.plist and select it.
  4. Hold down the alt/option and drag it to your Desktop to copy it there.
  5. Upload that file here in a reply.

@dswindle, @GAG, @antoine …we still cannot reproduce this crash on our end. It may be useful to have your preferences as well to see if we can reproduce this crash.

Sure thing. The forum doesn’t allow .plist files to be uploaded, so I’ve renamed the extension .3dm, you should be able to change to .plist once donwloaded I assume.com.mcneel.rhinoceros.3dm (356.6 KB)

Whoops. Thanks. I just diddled a setting in Discourse…hopefully now .plist is a valid upload.

Unfortunately, I’m still unable to reproduce the crash with your preferences @ecnal_van_maanen :confused: It was worth a try.

Boooo! And thanks for trying. Out of curiosity, do you think this is a small sample of wip osx users affected, is there enough penetration of the install to gauge?

It is difficult to tell. I suspect this is a smaller percentage of the RhinoWIP (5E292w). In the past two weeks, there have been ~5000 launches of RhinoWIP 5E292w…only a small number have submitted crash reports and a smaller group still (thank you!) have engaged us here. We need to fix this, regardless. It’s a bit of a show-stopper.

PS: We thought we knew where the regression was…but now we’re not so sure.

Cool, thanks- good to know.

Well, as far as I can remember- no changes to my system around the time of the breakage.

I’ve got a few colleagues running a previous wip in the office (same system specs), I’ll get them to have a go at the latest wip and see if they can replicate also.

EDIT: Interesting, looks like it’s just me! No other crashed from 2 installs on other machines. Bizarre.

Could please submit new crash reports when running 5E326w? We would like to see if the crash report has any new information in it. Thanks.

@ecnal_van_maanen I am assuming that you have updated to 10.12.6. There definitely were problems with the original release of 10.12 that Apple fixed in later updates. Could you post your current Rhino information, along the the Rhino information of your colleagues’ computers that do work.

I was running 10.12.1, but just updated to 10.12.6 and same issue. Crash dump sent to mcneel, system specs here:

Software information

Software versions
Rhinoceros version: 5.4 WIP (5E326w)
Rhinoceros path: /Applications/RhinoWIP.app
IronPython version: 5.1.2015.131
WIP expiration: 13 January 2018
Language: en-AU (MacOS default)
macOS version: Version 10.12.6 (Build 16G29)

Plug-ins
None

Third party kernel extensions
com.logitech.manager.kernel.driver (6.70.1) BF95D805-77E8-37EC-B75E-88BBCC75B710

Hardware information

Computer hardware
Hardware model: iMac17,1
Processor: Intel Core i7-6700K CPU @ 4.00GHz
Memory: 32 GB
Architecture: Intel 64 bit

Video hardware
Graphics: AMD Radeon R9 M395X 4096 MB
Memory: 4096 MB
Screen size: 2880 x 1620
Displays: iMac (244dpi 2x)

USB devices
PixArt: USB Optical Mouse
Apple, Inc: Apple Keyboard
Broadcom Corp.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)

Bluetooth devices
Unknown:

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.51.8
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

Colleague non crashing:

Software information Software versions Rhinoceros version: 5.4 WIP (5E326w) Rhinoceros path: /Applications/RhinoWIP.app IronPython version: 5.1.2015.131 WIP expiration: 13 January 2018 Language: en-AU (MacOS default) macOS version: Version 10.12.6 (Build 16G29) Plug-ins None Third party kernel extensions None Hardware information Computer hardware Hardware model: iMac17,1 Processor: Intel Core i5-6600 CPU @ 3.30GHz Memory: 8 GB Architecture: Intel 64 bit Video hardware Graphics: AMD Radeon R9 M395X 4096 MB Memory: 4096 MB Screen size: 2560 x 1440 Displays: iMac (217dpi 2x) USB devices TOSHIBA: TransMemory Broadcom Corp.: Bluetooth USB Host Controller Apple Inc.: FaceTime HD Camera (Built-in) Apple Inc.: Apple Keyboard Microsoft : Microsoft Basic Optical Mouse v2.0 Apple Inc.: iPhone Bluetooth devices None OpenGL information OpenGL software OpenGL version: 2.1 ATI-1.51.8 Render version: 2.1 Shading language: 1.20 Maximum texture size: 16384 x 16384 Z-buffer depth: 24 bits Maximum viewport size: 16384 x 16384 Implementation settings Use texture compression: No Appearance settings Antialiasing: 4x Mip map filtering: None Anisotropic filtering: None

EDIT: looks like they have the i5 processor, so not same system actually.

Having the same problem. Can’t open files in RhinoWIP although I was working on them normally in Rhino. Any fix for this? Any links where I can download a previous RhinoWIP version that works?

com.mcneel.rhinoceros.plist (496.1 KB)

just updated to 5E326w, still crashing on boot.

Same here. Any forecast as to when a fix will be out?

Software information

Software versions
Rhinoceros version: 5.4 WIP (5E326w)
Rhinoceros path: /Applications/CAD/RhinoWIP.app
IronPython version: 5.1.2015.131
WIP expiration: January 13, 2018
Language: en-HK (MacOS default)
macOS version: Version 10.12.6 (Build 16G1036)

Plug-ins
None

Third party kernel extensions
com.paragon-software.filesystems.ntfs (911.0.15) F29E189F-F66B-3880-88D3-D313F2E9E11D
org.virtualbox.kext.VBoxDrv (5.1.28) C0F0EDBE-F7FA-3189-8D24-48F02415C348
org.virtualbox.kext.VBoxUSB (5.1.28) 93025612-D707-3185-AA16-5D987EA2F72E
org.virtualbox.kext.VBoxNetFlt (5.1.28) F8FCB36B-980B-3823-BFCB-765E43593678
org.virtualbox.kext.VBoxNetAdp (5.1.28) 6AE4C456-BA43-328E-8464-1CAA4C6F7BB8
foo.tun (1.0) FBA9A61D-E7BB-391C-92E2-C1D85BB065B2
foo.tap (1.0) FF769517-6401-3F61-9190-B967BF20C0B2
com.getdropbox.dropbox.kext (1.8.7) 5F74386D-1150-356D-B468-88F953882193

Hardware information

Computer hardware
Hardware model: MacBookPro11,3
Processor: Intel Core i7-4850HQ CPU @ 2.30GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 750M 2048 MB
Memory: 2048 MB
Screen size: 1440 x 900, 2560 x 1440
Displays: Color LCD (221dpi 2x), Thunderbolt Display (109dpi 1x)

USB devices
Seagate: BUP BK
Apple Inc.: FaceTime HD Camera (Display)
Apple Inc.: Apple Thunderbolt Display
Apple Inc.: Display Audio
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller
Apple, Inc: Apple Keyboard
Logitech: USB Optical Mouse

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.17.5 355.10.05.45f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

Updated macOS to High Sierra Version 10.13.1. Now it seems to be working fine. Will provide updates if anything happens.

Please, release previous version 5.4 WIP 5E236 with extended expiration.49
Working version expires today and new version isn’t working, so I need urgent solution, please )

same for me
the last WIP expired and now the new one crashes on opening any file [Inc new]
I have submitted a crash report
hope this get sorted out soon.
thanks a lot
akash

software info:
Software information

Software versions
Rhinoceros version: 5.4 WIP (5E326w)
Rhinoceros path: /Applications/RhinoWIP.app
IronPython version: 5.1.2015.131
WIP expiration: 13 January 2018
Language: en-IL (MacOS default)
macOS version: Version 10.12.6 (Build 16G29)

Plug-ins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient

Third party kernel extensions
com.3dconnexion.driver (10.4.4) 18C5C020-DF5F-372B-BA0D-B123E748DEE4
com.rim.driver.BlackBerryUSBDriverInt (0.0.67) 3D68C30B-05F8-FB91-8606-B0F892DAA206
com.nvidia.CUDA (1.1.0) 5AFE550D-6361-3897-912D-897C13FF6983
com.sophos.kext.oas (9.6.53) E7883FE6-B498-37ED-BDBB-9BC0EC59DCDE
com.sophos.nke.swi (9.6.51) B9C6AF49-49A7-3666-97EE-FFA2E2E387FD

Hardware information

Computer hardware
Hardware model: MacBookPro11,3
Processor: Intel Core i7-4960HQ CPU @ 2.60GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 750M 2048 MB
Memory: 2048 MB
Screen size: 1440 x 900
Displays: Color LCD (221dpi 2x)

USB devices
Apple: Card Reader
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller
3Dconnexion: SpaceNavigator for Notebooks
Generic: Mass Storage Device

Bluetooth devices
Apple: Apple Magic Mouse

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.17.5 355.10.05.45f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

This ought to be fixed in the latest RhinoWIP (5E334w). Please give it a try.

Thanks again to all who helped us track this one down and help test.