Ladybug 0.0.68 with RiR stopped working

I’m using Ladybug Tools version 0.068 in Rhino.Inside file but recently SunHoursAnalysi s Component stopped working. The error is: 1. Solution exception:index out of range: 0

I’ve tried with external file (from Revit) just to put the same Interalise Data to SunHoursAnalysi component and everything worked correctly. I’ve noticed that in Rhino.Inside files works fine with Ladybug version 1.2.0 (LB Direct Sun Hours with the same data input). Unfortunately I need to receive back the input sunIsVisible in data structure like it was built in version 0.0.68 - all grid points sunIsVisible result presented in separate tree branches (see picture below).


I would like to resolve the problem using both Rhino.Inside Revit with Ladybug 0.0.68 but in order to do this I need to get int_matrix from new LB Direct Sun Hours component in previous data tree structure - all grid points sunIsVisible result presented in separate tree branches.

I’ve tried to replace paths in data tree from LB Decontruct matrix component but I get errors.

I’ll appreciate any help how to replace the path just to get the structure of SunIsVisible output like It was in Ladybug v.0.0.68.
Ladybug_sunHours stop working_forum request.gh (427.4 KB)

Is this a Ladybug issue or RiR one?

I supossed that this is RiR problem with version 0.0.68 because when I’ve open file outside RiR everything working ok and the error (1. Solution exception:index out of range: 0) didn’t appeared.